1

I need to upgrade my Redmine installation. I'm on a Mac OS X Server 10.6.8 (unfortunately, this is a given - can't update the system to a new version right now).

In the process, I had issues with installing a newer version of Ruby (required by the new Redmine version), and ended up with rbenv which now maintains everything Ruby on the system. Had some more trouble with updating Passenger, until I found out that they had dropped support for 10.6.8 a long time ago.

I was able to install Passenger (and its Apache2 module) in the end, albeit the same version I was running before the upgrade - so this is now Passenger 4.0.5. But it is running, and I was also able to confirm that my app (Redmine) is still there, in its updated form, through Passenger standalone. However, I'd like to serve Redmine through Apache, and all I get is a 403 error, with the Apache log saying the following:

[Mon Feb 06 18:00:13 2017] [error] [client XXX.XX.XX.XXX] Directory index forbidden by Options directive: /Library/WebServer/Documents/redmine/

Here are the contents of my conf file for the virtual host (somedomain hides my hostname):

<VirtualHost *:80>
   ServerName somedomain/redmine
   # !!! Be sure to point DocumentRoot to 'public'!
   DocumentRoot /Library/WebServer/Documents/redmine/public    
   <Directory /Library/WebServer/Documents/redmine/public>
      # This relaxes Apache security settings.
      AllowOverride all
      # MultiViews must be turned off.
      Options -MultiViews
   </Directory>
</VirtualHost>

I'm currently not using the Passenger Preferences Pane. My Redmine folder is in /Library/WebServer/Documents/redmine. Should it be somewhere else? It used to sit in /Library/WebServer/Ruby_Apps before, and I had a symlink going from /Library/WebServer/Documents/redmine to the public directory. What is the better way of doing things?

Can anyone point me towards a solution? Let me know if you need more information.

0

In the short term it looks a index-listing issue. The following options can fix that:

Options +Indexes +FollowSymLinks -MultiViews

There is no guarantee other issues are waiting.

| improve this answer | |
  • Thanks for this. I get the very same error after entering the options you gave into the conf file. What else could be going wrong? Let me know what you need from me to get to the source of this. – Sebastian Sulger Feb 8 '17 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.