0

I am adding automatically created virtual machines as pre staged devices on our WDS and giving them full join rights

New-WdsClient -DeviceId $macAddress -DeviceName $name -BootImagePath "Boot\x64\Images\boot.wim" -JoinRights Full -Domain "sievolab.int" -JoinDomain $true -OU $serverOU -User "$($env:UserDomain)\$($env:username)" -PxePromptPolicy NoPrompt -WdsClientUnattend "WdsClientUnattend\labbuildslave.xml" -ReferralServer $wdsServer

This works great when installing manually but I recently started implementing the two unattended files so that we could have 100% automatic installations. Thing is if I don't join the domain in the ImageUnattend file it will not join the domain at all.

Is there a way of not specifying the domain/OU in the Unattended files and just use the rights given at prestage?

0

When creating the answer file with Windows System Image Manager under 4 specialize -> Microsoft-Windows-UnattendedJoin -> Identification set UnsecureJoin to true.

I'm still specifying the domain explicitly, but it can be propably removed and be left up to the powershell command. I suspect this because I am not setting the MachineObjectOu and that is still setting correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.