0

I am developing on a machine that is not connected to the company's domain.

  • I am connected to the company VPN
  • When debugging/running the project from Visual Studio 2015, most things work fine. The error I'm running into is that on a remote server the app needs to create a folder
  • I have tried doing runas /netonly /user:domain\user "devenv.exe" for VS2015 with my domain credentials, but that does not seem to work
  • I am running the app on the machine's IIS app pool

I am trying to run the application I have under IIS that requires permissions to create folders on a remote server. I can connect to this remote server through windows explorer. The company provides an account specifically for the IIS app pool identity which I also tried creating locally and using, yet I still get the error: “The user name or password is incorrect.

Connecting to SSMS works great using runas, but I can't get visual studio to work with it. I do not want to join the domain to resolve this issue, are there any options available?

  • You haven't actually described the problem. What exactly are you trying to do and what happens when you try to do it? What messages, if any, are you getting? What are the symptoms of the problem? – joeqwerty Feb 9 '17 at 5:09
  • I am trying to run the application I have under IIS that requires permissions to create folders on a remote server. I can connect to this remote server through windows explorer. The company provides an account specifically for the IIS app pool identity which I also tried creating locally and using, yet I still get the error: “The user name or password is incorrect.” – 1101_01 Feb 9 '17 at 5:30
  • Could you update your question to give a bit more detail on when this works, and when it doesn't? Is there a reason joining the domain isn't an option? – iwaseatenbyagrue Mar 6 '17 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.