Can someone help me out with how to redirect an URL that has an address record?

The situtation is as follows:

I am trying to resolve a WordPress URL (groups.regalcouch.com) to a subdirectory (groups.regalcouch.com/docs/index.php).

Clicking on the first link brings up the Apache page of the machine that is hosting my WordPress website. The first link is resolved correctly but leads to the Apache page of the Debian host.

My configuration is as follows:

-Debian 8 VM hosted within an ESXi environment

-Windows Server 2012 running DNS Manager and IIS 8

WordPress has been installed as described here: http://www.linuxserve.com/2015/05/install-latest-wordpress-version-on.html

Which things I have edited and what the results were:

-Added A record in the DNS Manager (which resolved almost perfectly but it did not resolve to a subdirectory)

-Added a new site in IIS (The confusion started here for me since I don't host WordPress in IIS)

I do have the feeling that I either have to edit settings in my WordPress installation (more about that here: How to change WordPress intranet URL) OR I do have to make an entry in IIS but further configure it.

  • 1
    Please add a lot more information about your environment, about what you did, what you expected and what happened instead. – Sven Feb 10 '17 at 16:13
  • I added more information and also back to an other question I posted regarding this issue. – SP-Brown Feb 13 '17 at 11:06
  • 1
    DNS records don't resolve to directories. – user9517 Feb 13 '17 at 11:12
  • Hence I resorted to IIS trying to resolve the subdirectory but that confused me.... – SP-Brown Feb 13 '17 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.