0

Today I tried to configure my Virtual Lab (VMWare) to access the Internet via a server configured for the purpose of doing the Routing. To do that, I followed this tutorial https://www.youtube.com/watch?v=pkL5Cfmov2w

All seemed just fine. I installed Windows Server 2012 R2 with Routing and Remote Access Server, configured to Network Cards on My Gateway (on on the LAN, another one on the corporate network with Internet access) and performed each and every step that I believed needed to be done. After all those steps, even though I can access the Internet from the gateway, any other servers on my lab are still not able to connect to the internet

Here is a summary of my configs:

  • My Lab is in the Domain 192.168.50.0/24
  • My Gateway is configured with the LAN ip to 192.168.50.254 and the WAN ip to DHCP
  • My lab PC's have the Default Gateway set to the LAN on the Gateway (192.168.50.254)
  • The Domain Controller on that network (192.168.50.10) acts as DNS and DHCP for the Lab, all PC's have that IP as their DNS Server.

Tests I did I can do more upon request if you want to help me :)

nslookup www.nytimes.com (from the Gateway)

Server: UnKnown

Address: 192.168.65.2

Non-authoritative answer:

Name: nytimes.map.fastly.net

Address: 151.101.53.164

Aliases: www.nytimes.com

nslookup www.nytimes.com (from a few of the lab computers)

DNS requested timed out.

  timeout was 2 seconds.

Server: UnKnown

Address: ::1

ping www.nytimes.com (from the Gateway)

Pinging nytimes.map.fastly.net [151.101.53.164] with 32 bytes of data:

Request timed out.

Request timed out.

....

ping www.nytimes.com (from a few of the lab computers)

Ping request could not find host www.nytimes.com. Please check the name and try again.

tracert www.nytimes.com (from the Gateway)

Tracing route to nytimes.map.fastly.net [151.101.53.164]

over a maximum of 30 hops:

1 <1 ms <1 ms 192.168.65.2

2 1 ms 1 ms 192.168.1.254

3 * * Request timed out.

[... and so it goes]

tracert www.nytimes.com (from a few of the lab computers)

Unable to resolve target system name www.nytimes.com

Please let me know if you need any other config info, print-screens or log files (I can provide all that) or other tests you want me to run.

Thanks a ton!

0

Even though I did not receive any suggestions this time, I decided to come back and finish my story telling how things were fixed in case anybody else happens to have a similar problem and is looking for clues.

Turns out that my problem was related the gateway not using the right DNS Server to resolve addresses outside my LAN. I changed the "Preferred DNS Server" on my Lab gateway to use the DNS the host computer (hosting all the VM's in my Lab) was using (as opposed to use the LAB's internal DNS).

I'm not sure if some other change did make a difference (I introduce some other changes together with that one) but I'm pretty sure it was DNS name resolution for sure.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.