2

I have munin and munin-node installed on a "master" server, (lets call it server1) and munin-node installed on a second server (let's call that one server2)

I am fairly certain that my configuration files are correct, but I can't get the second server to show! This is irritating because reading -man and Google-ing, Munin is not rocket science! I must be missing something simple.

server1's hostname: server1.com -- ip address: 10.2.6.60

server2's hostname: server2 (without the .com) -- ip address: 10.2.6.80

server1.com's config /etc/munin/munin.conf:

[server1.com]
    address 127.0.0.1
    use_node_name yes

[server2]
    address 10.2.6.80
    use_node_name_yes

server2's configuration /etc/munin/munin-node.conf

log_level 4
log_file /var/log/munin/munin-node.log
pid_file /var/run/munin/munin-node.pid

background 1
setsid 1

user root
group root

ignore_file [\#~]$
ignore_file DEADJOE$
ignore_file \.bak$
ignore_file %$
ignore_file \.dpkg-(tmp|new|old|dist)$
ignore_file \.rpm(save|new)$
ignore_file \.pod$

host_name server1.com
allow ^10\.2\.6\.60$

host *

port 4949

Here's my telnet to server2 from server1

telnet 10.2.6.80 4949
Trying 10.2.6.80...
Connected to 10.2.6.80.
Escape character is '^]'.
# munin node at server1.com

server2 log (you'll notice the last two entries -- those are my telnet attempts, however you'll notice that there's no other connection attempts by munin itself):

2017/02/15-17:43:18 Munin::Node::Server (type Net::Server::Fork) starting! pid(33478)
Resolved [*]:4949 to [::]:4949, IPv6
Not including resolved host [0.0.0.0] IPv4 because it will be handled by [::] IPv6
Binding to TCP port 4949 on host :: with IPv6
Setting gid to "0 0"
2017/02/15-17:44:03 CONNECT TCP Peer: "[::ffff:10.2.6.60]:40924" Local: "[::ffff:10.2.6.80]:4949"
2017/02/15-17:52:25 CONNECT TCP Peer: "[::ffff:10.2.6.60]:40928" Local: "[::ffff:10.2.6.80]:4949"

I'm stumped!!

2

Did you resolve this situation? I believe the issue is in the server2 configuration file. In this file, one finds the line:

host_name server1.com

This line should either be "server2" or commented out if the hostname returns the correct information.

(from munin-node.conf):

host_name: The hostname used by munin-node to present itself to the munin master. Use this if the local node name differs from the name configured in the munin master.

The issue may be seen in the telnet output to server2 from server1, and it reports:

# munin node at server1.com

It should report server2.

If you look in the log files on server1 at /var/log/munin/munin-update.log, there may have been an entry similar to:

2017/08/15 16:35:02 [INFO] node server2 advertised itself as server1.com instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.