3

we're currently have some weird issue with our organization's Exchange Server 2010:

Although on the server the attachment size is set to 55000000 bytes in the web.config file for OWA, users cannot attach files larger than approx. 25 MB.

Here's some more details and steps to reproduce (screenshots are in German...)

  1. Open OWA web page

  2. Log on using AD credentials

  3. Create a new mail new mail window of OWA

  4. Click the paperclip icon (add attachment)

  5. A Common Dialog (FileOpenDialog) is shown

  6. Select a large file (approx. 30 MB) to upload and start the upload.

  7. after some seconds, an error message is shown: action couldn't be completed error (English: The action you tried to perform couldn't be completed because there's a configuration problem on the server. If the problem persists, please contact Helpdesk.)

  8. Any ideas, why this message is shown? It doesn't explicitly mention any size limit being exceeded... But strangely, smaller files can be attached without any problem.

Some additional information:

  1. Upload attachment after above error message

a) Sismiss dialog box and click the paperclip icon once again)

b) Strangely, now there's a different dialog box being shown. Now it's not a Windows dialog box anymore, but a HTML element: different attachments upload dialog

(The German text does not really matter. It more or less explains how to attach a file. The button "Durchsuchen..." ("Browse...") lets the user select a file and the link "Anfügen" ("Attach") attaches that file to the mail.)

c) Now, the file can be uploaded without an error message being shown. (File size: 25 MB)

  1. Upload an 40 MB ASCII Text file (only characters A-Za-Z)

a) create a new mail

b) click the paperclip icon to attach a file and select a 40 MB ASCII text file.

c) Start the upload.

d) The following error message is shown: message exceeds maximum size error (The message box says: The following files weren't attached because they exceed the maximum size limit for attachments (40 MB): char42. ) [or similar]

e) When seeing this error message, it is clear that the attchment size is to high.

--> Why is that message shown here, but not in the 25 MB binary file as mentioned above.

--> The size limitation is set to 55000000, why is then 40 MB shown in the error message?

Did anyone already see a similar behaviour?

Does anyone know how to fix this issue and to be able to upload (binary) files larger than 25 MB?

Best regards,

Tom

PS: I asked the same question also on Technet (Technet Link)

  • p.s. the company name is seen in your last screenshot. You might wish to replace that as well (similar as in both first screenshots). – BastianW Feb 16 '17 at 14:21
1

I mixed my first answer up.

Go to Organization Configuration, Hub Transport, Send Connector tab. Right-click your send connector, go to Properties and set the Maximum message size to 55000 on the General Tab.

Next, go to Server Configuration, Hub Transport, and under Receive Connectors, right-click the receive connector and go to Properties. Under the General Tab, set your maximum message size to 55000.

|improve this answer|||||
  • It's already set to >100000... – TomS Feb 16 '17 at 15:14
  • There was still a setting in the web.config which was not yet set to a higher value... – TomS Mar 21 '17 at 10:53
1

Although you are attaching a 40 megabyte ASCII file, all email programs will helpfully mime encode all files for you. Even ASCII files.* It doesn't look at the file content because email wasn't designed to send files initially. The mail standard is only for text, and any attachments or inline pictures are MIME (base 64) encoded prior to their attachment. There is no function to examine file content, prior to encoding.

Mime encoding adds about 70% to the size of encoded files putting you over the 55000 limit.

Rather than trying to email large files, they should be transferred over sftp or another file transfer method. Alternately, you should compress them before sending, however from problems with mailed virus infections, many attachment types are blocked at the receiving end.

The other thing to watch out for is sending large files between domains. I can't tell from stack mobile is if you are sending it to yourself or to an offsite host which may have a Smaller allowed mail size limit. You would need to caution users that they would not be able to send as large of a mail message outside of the company because of those limitations.

|improve this answer|||||
  • Oh, thanks for that information! I did not know that. – TomS Feb 19 '17 at 6:44
  • @TomS I improved my answer somewhat to provide background and alternative suggestions. If this addresses your issue please accept the answer so that other users can see this was the solution without asking their own questions. Thx. – Rowan Hawkins Feb 21 '17 at 6:55
  • I agree with you on the 40 MB file. It might become larger than 55000 bytes by the Base64 encoding... But why can't the 30 (exactly: 26 MB) file from the first part of my post be sent? And why can it be sent if I retry it? For me, it seems that it's not a server-side size limitation. – TomS Feb 21 '17 at 10:01
  • @TomS I am confused. Your question says that the 25mb file works and the 40mb file doesn't. It doesn't say anything about the 25mb file NOT working. – Rowan Hawkins Feb 21 '17 at 10:19
  • @TomS As Jarod mentioned in his answer you need to set both the receive window and the send window to be the size that you want to be able to send stuff. --If you are trying to send to another domain your largest send size can be anything you want but the mail will not go through if it is larger than their receive size. I edited my message above earlier to explain that. Some providers change the amount that they will allow somebody to send or receive based on whether or not they pay for service. For instance Gmail, if you have a business account it's 25MB and 10MB otherwise. – Rowan Hawkins Feb 21 '17 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.