2
 systemctl status openvpn
● openvpn.service - OpenVPN service
   Loaded: loaded (/lib/systemd/system/openvpn.service; enabled)
   Active: active (exited) since Thu 2017-02-16 15:11:44 EST; 22h ago
  Process: 29607 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 29607 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/openvpn.service

and

Feb 16 15:11:44 server.local systemd[1]: Started OpenVPN service.
Feb 16 15:15:20 server.local systemd[1]: Started OpenVPN service.
Feb 16 15:15:47 server.local systemd[1]: Started OpenVPN service.
Feb 16 15:22:37 server.local systemd[1]: Started OpenVPN service.
Feb 16 15:23:44 server.local systemd[1]: Started OpenVPN service.
Feb 17 13:36:16 server.local systemd[1]: Started OpenVPN service.

and

I've looked in /var/log/syslog and don't see anything. I've checked in /etc/openvpn for logs and nothing.

Config:

local 0.0.0.0
port 1194
proto udp
dev tun
ca ca.crt
cert server.crt
key server.key
dh dh2048.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 208.67.222.222"
push "dhcp-option DNS 208.67.220.220"
client-to-client
duplicate-cn
keepalive 10 120
comp-lzo
max-clients 100
user root
group root
persist-key
persist-tun
status openvpn-status.log
log         openvpn.log
log-append  openvpn.log
verb 9
mute 20

How can I figure out why it will not start?

This is:

cat /etc/debian_version
8.7
  • Why is your openvpn binary called /bin/true? ExecStart=/bin/true – Phillip -Zyan K Lee- Stockmann Feb 17 '17 at 19:24
  • Do not know. I installed from apt-get – Jason Feb 17 '17 at 19:27
  • Has to be something Debian-specific. Even so I can't imagine any reason to be starting /bin/true instead of, you know, OpenVPN. My second thought would be to file a bug report (and you probably don't want to know my first thought). – Michael Hampton Feb 17 '17 at 23:37
  • @MichaelHampton I probably know your first thought.. but I will dig deeper and bug report this. I've installed OpenVPN over 20 times this month and I've gotten it down to 5-10 minutes so this was the first time I've had this happen. – Jason Feb 18 '17 at 0:58
1

Like nearly every other of systemctl's .service files, one can find the relevant openvpn .service files in /lib/systemd/system.

As explained by openvpn's service file located at /lib/systemd/system/openvpn.service:

# This service is actually a systemd target,
# but we are using a service since targets cannot be reloaded.

One instead finds the proper .service file in openvpn@.service, indicating that he should start the openvpn service under his desired user with systemctl start openvpn@whicheveruser.service and enable the openvpn service with systemctl enable openvpn@whicheveruser.service.

The default openvpn@.service loads its configuration from /etc/openvpn/whicheveruser.conf. If one wants to change this, perhaps to /etc/openvpn/server.conf, he should alter openvpn@.service's ExecStart command to his preference.

  • 1
    What on earth is Debian doing here? – Michael Hampton Feb 19 '17 at 6:52
  • EL uses the same syntax @MichaelHampton. – Iain Feb 19 '17 at 7:16
  • 1
    @istheEnglishway EL does not have an openvpn.service, only openvpn@.service. – Michael Hampton Feb 19 '17 at 7:19
0

So I finally fixed this or it just started working when I came back to it a day later.

After doing a systemctl daemon-reload again it seems to have fixed the issue and I was able to start OpenVPN. Not sure why this installation was different then all the one's I've done time and time before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.