1

I am setting up an LXC container on a fresh install of Proxmox 4.4. My network setup is analagous to the one described in this post: network configuration (bridging) proxmox

However, I still cannot access the container from the local network, and the container cannot ping to the outside. The container and the host can both ping each other fine.

Here's the host /etc/network/interfaces

auto lo
iface lo inet loopback

iface eth0 inet manual

auto vmbr0
iface vmbr0 inet static
     address 192.168.1.45
     netmask 255.255.255.0
     gateway 192.168.1.1
     bridge_ports eth0
     bridge_stp off
     bridge_fd 0

and the container's /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
     address 192.168.1.78
     netmask 255.255.255.0
     gateway 192.168.1.1

iface eth0 inet6 dhcp

I'm really not sure what I'm doing wrong. I thought this was about as simple a network setup as one could have with Proxmox. Can anybody help me?

Full disclosure: I am previewing this as a VM in ESXi 6.5, but it does not seem as if that should matter in this situation.

Thanks!

Edit: I figured out what the problem was and wanted to post it here so it could help if anyone else had the same problem.

In ESXi, promiscuous mode needs to be configured at the vSwitch. This allows nested VMs and containers to use bridging. Please see this article for further information: https://egustafson.github.io/esxi-nested-virtualbox.html

2

I had the same problem with esxi 6.5. I fixed it this way: in the settings of the virtual switch, the Security tab, we set all values in Accept. And now everything works!

security settings

  • 1
    That's "accepting" promiscuous mode. – AveryFreeman May 17 '17 at 12:55
0

I tested this with Proxmox 5 on ESXi 6.5. You only need to allow MAC address changes. This is like disabling port security on Cisco hardware; this allows you to use more than one MAC address on one port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.