1

so i have a server with Ubuntu 16.04. There runs a Squid ( Squid Cache: Version 3.5.12 ). It should function as forward proxy, authenticating the user then leading him/her forward to a peer.

But Squid just starts then stops after like 20sec and then starts again.

Feb 20 10:11:41 proxy squid[12566]: Squid Parent: (squid-1) process 23215 exited due to signal 6 with status 0
Feb 20 10:11:44 proxy squid[12566]: Squid Parent: (squid-1) process 23321 started
Feb 20 10:12:09 proxy squid[12566]: Squid Parent: (squid-1) process 23321 exited due to signal 6 with status 0
Feb 20 10:12:12 proxy squid[12566]: Squid Parent: (squid-1) process 23429 started
Feb 20 10:12:37 proxy squid[12566]: Squid Parent: (squid-1) process 23429 exited due to signal 6 with status 0
Feb 20 10:12:40 proxy squid[12566]: Squid Parent: (squid-1) process 23535 started
Feb 20 10:13:05 proxy squid[12566]: Squid Parent: (squid-1) process 23535 exited due to signal 6 with status 0
Feb 20 10:13:08 proxy squid[12566]: Squid Parent: (squid-1) process 23608 started
Feb 20 10:13:33 proxy squid[12566]: Squid Parent: (squid-1) process 23608 exited due to signal 6 with status 0
Feb 20 10:13:36 proxy squid[12566]: Squid Parent: (squid-1) process 23722 started

I have no idea why. I red in other forums that you have to delete the cache and rebuild it but that did not help.

squid.conf passes the squid -k reconfigure so iam pretty sure its not in the config.

I hope somebody could help me to fix that.

thanks for you time.

EDIT: Not sure if it helps. In the short period the squid is active, it works fine. So I can connect and authenticate and get to the internet.

EDIT 2 : Last lines from cache.log

2017/02/20 11:29:27.751 kid1| ctx: exit level  0
2017/02/20 11:29:27.751 kid1| 20,2| store.cc(954) checkCachable: StoreEntry::checkCachable: NO: not cachable
2017/02/20 11:29:27.751 kid1| 20,2| store.cc(954) checkCachable: StoreEntry::checkCachable: NO: not cachable
2017/02/20 11:29:27.751 kid1| 20,2| store.cc(954) checkCachable: StoreEntry::checkCachable: NO: not cachable
2017/02/20 11:29:27.751 kid1| assertion failed: stmem.cc:228: "target.range().end > target.range().start"

Edit 3: Update. Thanks to you and a lot of trying i could pin the problem down. Squid only starting and stopping and so on if i put in the second cache_peer. Without that it works fine.

6
  • what's the output of ulimit -n? – 13dimitar Feb 20 '17 at 9:27
  • Any error message in /var/log/squid/cache.log? – Khaled Feb 20 '17 at 9:29
  • ulimit -n gives me 1024 as root. I cant log in as the proxy user. getting This account is currently not available. /var/log/squid/cache.log no errors or warnings. just seeing Pinger exiting. – BitKoch Feb 20 '17 at 9:36
  • @BitKoch, please post your cache.log too. – Diamond Feb 20 '17 at 10:27
  • @bangal how much you need? its a pretty huge log. I will put something in the original post. – BitKoch Feb 20 '17 at 10:31
-1

Solved: So as i wrote that one cache_peer was troublesome and if active, squid would restart over and over again. I saw in the logs that it wanted a netdb from that cache_peer. So i added no-netdb-exchange to the options from the cache_peer in the etc/squid/squid.conf. Now it serves as wanted and doesn’t restart over and over any more.
Thank you all for helping and your time.

1
  • The question field is for questions and the answer field is for answers. – Sven Feb 23 '17 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.