0

Our Exchange 2010 server (v14.03.0339.000, which is the latest version as of February 2017) works fine (one single exchange server in the AD), except for the search index.

Resetting the search index (ResetSearchIndex.ps1 -Force -All, deleting the catalog folder, restarting search related services, rebooting the server etc.) didn't help, because:

ContentIndexState is Healthy after being Crawling for a few minutes after a catalog reset. Although being Healthy, the size of the catalog folder in the file system of the mailbox is just about 400KB (I read that the catalog size is generally supposed to be about 5-10% of the database size, which would be about 5GB in my case).

Perfmon shows 0 successfully indexed documents, while way beyond 200k documents are listed as failed.

Test-ExchangeSearch yields time out for test thread. In the event log, I get Event 9877: 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch. Error code: 0x80004005

Running Repair-ExchangeSearchSymLinks.ps1 and rebuilding the catalog as suggested here: https://blogs.technet.microsoft.com/exchange/2011/06/30/after-installing-exchange-2010-service-pack-1-searching-via-owa-or-outlook-online-mode-fails/ didn't help either.

Any ideas? Could 0x80004005 point towards an access denied issue?

Update: Creating a new mailbox database, moving mailboxes there and indexing yields the same error. Furthermore, I have created a new user with a mailbox, same issue here.

Result of Get-FailedContentIndexDocuments is Unknown error code 0x80004005 for each document, and the function ends with

Error 0xe0434f4d (Unknown error (0xe0434f4d)) from cli_GetDrmFailedItems
    + CategoryInfo          : NotSpecified: (0:Int32) [Get-FailedContentIndexDocuments], RpcException
    + FullyQualifiedErrorId : 5B3DED0E,Microsoft.Exchange.Management.Search.GetFailedDocuments
    + PSComputerName        : myexchangeserver.domain.com

I tend to think that the cause must be global, maybe in Active Directory itself.

  • Finding that isn´t that easy. Did you have more MailDBs (nor mailBoxes) in your environment, so that you could disable the indexing (via Set-MailboxDatabase -Identity MailboxName -IndexEnabled $false) for some DBs and then find the DB which caused that issue? – BastianW Feb 20 '17 at 13:51
  • Actually there is only one single mailbox database. However, what we did in December 2016 is migrate our old Exchange 2010 server to a new one (also Exchange 2010): Installing all roles on the new server, moving mailboxes and then uninstalling the old Exchange 2010 installation. Unfortunately I cannot tell if the search index worked prior to that process. In the meantime, the successful indexed document count has increased to 15, which is still not good, but also not zero. – Hannes Feb 20 '17 at 14:21
  • 1
    Hm I see, I think then you might have some "bad" document in one or some of the mailboxes. You might wish to build a new MailDB and then move mailbox by mailbox until the index caused again issues. This approach might help you to find the one which isn´t ok. Then you can check which problems you have with that specified mailbox and try to repair it. I know it might take some time here, but I do not know an easy way. – BastianW Feb 20 '17 at 16:52
  • I guess the 15 indexed documents were a result of Test-ExchangeSearch. After resetting the catalog again, successful index count was 0 again. I tried to create a new mailbox database and moved one mailbox to the new database, and did the same with another mailbox to exclude that this one mailbox was the cause. Same result, all documents were erroneous. So the issue cannot be database related imo. My user has read write access to all mailboxes and its documents, so could it be an issue with the permissions for the index service? – Hannes Feb 21 '17 at 7:16
1

Yes, issues are related to indexing in Exchange Server. Whenever Indexing issue arise in Exchange Event Code 9877 generated with specific id details, in your case Error code 0x80004005.

possibel cause of erro

Possible Resolution of the Error Code “0x80004005”

enter image description here

Know more about solution of error 0x80004005

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.