4

I've made a GPO that make a scheduled task. This scheduled task access to a network share to execute a powershell program that will delete some mails in outlook. Script is OK.

It's a User GPO. enter image description here

When i launch a gpupdate /force, scheduled task does not appears but the GPO appears to be executed in gpresult /R. It works only when i connect to computer with a user that have admin rights on computer.

id 4098 element user GPO was not applied because or error 0x80070005 acces denied.

Here the entire error message (in french) enter image description here

Any idea? thank.

  • Questions seeking installation, configuration or diagnostic help must include the desired end state, the specific problem or error, sufficient information about the configuration and environment to reproduce it, and attempted solutions. Questions without a clear problem statement are not useful to other readers and are unlikely to get good answers. – Daniel Feb 20 '17 at 15:31
  • Removed my downvote. This is a lot better. :) – Daniel Feb 20 '17 at 19:34
4

Found the issue.

Used this : https://support.microsoft.com/en-us/help/2447414/user-gpp-scheduled-task-item-fails-to-apply-and-logs-event-id-4098-with-0x80070005-access-is-denied.

To avoid this issue, do not enable the "Run in logged-on user’s security context (user policy option)” Common option when configuring user GPP Scheduled Tasks items.

The security context under which the Scheduled Task will run once it has been deployed can be specified in the General settings tab when creating the User GPP Scheduled Task item:

User Configuration\Preferences\Control Panel Settings\Scheduled Tasks\New\"Scheduled Task (Windows Vista and later)"

General:

Security Options -> "When running the task, use the following user account:"

By default, this is set to: %LogonDomain%\%LogonUser%

This is where the security context under which the scheduled task will run should be configured.

  • 3
    Thanks for letting us know the solution. Dont forget to mark your answer as accepted too please, as you can without problem. et bonne fin de journée :P – yagmoth555 Feb 20 '17 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.