3

I try to set the default application for .pdf files depending on the users group with a GPO. We have Adobe Acrobat Reader DC and Adobe Acrobat DC installed on a Windows Server 2012 R2 terminal server. There's a group for each application.

My attempt to solve this with folder options failed.

enter image description here

To set the default application via registry also failed. An unique hash is needed for each user and I don't know how to generate them.

Is there a simple solution for this problem ?

Thank you in advance.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

To set the default association please export HCU\Softwares\Classes\ (pdf related classes after) (twice for each acrobat product)

You can by login to the TS and make sure of the association are ok and just export a .reg and clean it after. (to not import all the classes)

If the RSAT tool are installed on the terminal you could use the Group Policy mmc GPP Registry Wizard to directly make the GPP.

  • Please note that you need to be logged on to make the dump or editing the GPO, in the GPP registry wizard you can connect to a remote machine, but the HCU's branch is not selectable that way.

If you make a GPO, you can do a reg import file.reg in a login script pushed by GPO with a security's filter depending on the Acrobat you want them to use.

  • Under HCU\Softwares\Classes\ I have a .pdf and a pdf_auto_file key. In .pdf is a string value (Name: (Default) | Data: pdf_auto_file). In pdf_auto_file\shell\Open\command is a string value (Name: (Default) | Data: "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe" "%1") Changing that value has no effect. User choice has unfortunately more priority. – pdunker Feb 24 '17 at 20:54
0

You need to specify the full path to the associated program. Judging by your picture, you simply put the name of the program file, but the system has no clue where to find it (after all, you could be referencing a portable program that isn't installed for all it knows). You can use environmental variables like %PROGRAMFILES% or %PROGRAMFILES(x86)% as needed. Also, this user configuration change requires you to log out and log back in to the computer (after doing a gpupdate /force at a command prompt) to take effect.

Here's a screenshot of one I just setup and tested: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.