4

On my Surface Pro 4 I'm missing a good bit of the functionality of RSAT. Here is what I'm seeing:


ADUC

Variety of tabs missing from the properties windows. I've turned on "Advanced Features": enter image description here

But when I open an OU's properties, all I see is Security, COM+, and Attribute Editor: enter image description here

When I open a user's properties, I'm also missing some pretty important tabs: enter image description here

Another fun bit is right clicking and adding a new user/OU/etc just doesn't do anything at all.

And randomly the Properties options doesn't do anything and you have to close ADUC and reopen it to get into the properties.


ADAC

If I scroll down to the bottom of a user, various tabs from Extensions are missing. For instance, no Attribute Editor: enter image description here

Other times opening a random user/OU/etc results in "Active Directory Administrative Center must close due to an unknown error" messages.


I've tried removing RSAT and re-installing it. I've made sure all of RSAT is installed. I've also copied tsuserex.dll and tsuserex.dll.mui from a working 2012 machine into system32 and system32/en-us and registered the DLL. None of that has resolved the issue. Also verified that en-US is the only language installed. Any other ideas?

  • 1
    Just for fun, I formatted the machine and started over. Same thing on a fresh install. Which makes me think the problem is server-side? – MSCF Feb 22 '17 at 17:50
  • It's not server side because I've had this problem and fixed it for myself, but I can't remember the fix. – Todd Wilcox Aug 23 '17 at 17:42
1

We had this issue on two machines, installing the anniversary update solved it for one, not the other. Reinstalling Windows didn't fix the other until we installed the anniversary update. We are not sure what the installation of the anniversary update does to fix this. We tried everything under the sun (re-registering DLL's, etc.).

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.