1

I have a Dell Precision T5400 with two 500 GB hard drives in RAID 1 using the motherboard RAID controller. I ran out of expansion room in the case, so I am moving to a Precision T7500, also with built-in RAID. I have done this before, but never with RAID enabled.

On the cheap Dell RAID cards, it appears creating a RAID array always wipes the disks, even when they were part of the same type of RAID array on a different system. To get around that, I used Windows Backup and Restore to create a System Image on an external hard drive. The image includes a 500 MB system partition and a ~456 GB primary partition.

When I boot into recovery mode on the T7500 to restore the image, it gives me an error:

System image restore failed. Disk set as active in BIOS is too small to recover the original system disk. Replace the disk with a larger one and retry the operation (0x80042407)

This is despite the disks in the machine being exactly the same ones that were in the old machine. WinPE sees the RAID array just fine and there are no other disks in the machine which could be the active disk.

I tested the image and I can restore it to a 1TB drive (so I know the image is OK), but that drive is old and has known reliability issues, so I can't just use it (plus I still want RAID 1).

How can I get this image to restore?

  • If you know you can restore to the larger disk, why not do that and then use Clonezilla (or any similar tool) to copy it back to the RAID array? It's not ideal, but it will save you the headache of dealing with this. – Moshe Katz Feb 22 '17 at 16:49
  • 1
    I have had similar problems restoring Win SysImg when booting from a USB device (or having another USB drive plugged in). After choosing the image and clicking next there should be a screen with an "Advanced" button. Go in there and make sure to un-select all the drives except your internal RAID array so they aren't options for the restore. That has been my A-1 issue with this kind of restore in the past. Also, make sure boot type (UEFI vs BIOS) is the same as the machine the image was captured on. – Ruscal Feb 22 '17 at 19:50
  • Thanks @Ruscal. I tried that and it didn't help. In the mean time I purchased two new 2TB disks. I will keep the image around for a while to try again if anyone posts an answer. – yakatz Feb 23 '17 at 18:20
  • You might consider Moshe's recommendation of using a clone/migration/backup solution (Clonezilla among many other options). Also, if your HDDs are good and both systems use the same generation PERC controller for the RAID, then you can actually slide the disks into the new server and have it read the RAID config off of the disks. We've had to do that before at my office, but we prefer not to since new HW gives us a chance to "make better choices" – Ruscal Feb 23 '17 at 18:32
  • I have the LSI 1068e controller on the motherboard, not the PERC, so the RAID config isn't saved on the drives. As I mentioned, if I can't restore to the original drives, I will just keep using the new ones that I purchased. – yakatz Feb 26 '17 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.