0

I have newly installed Windows Server 2012 R2 with IIS 8. I have added a SSL certificate through pfx file and when I try to access the site with browser I get this promt that asks client for certificate. It happens in Edge, safari and chrome. This is not desired, all I wanted was to have an SSL connection.

Do you have an idea what might be causing this?

Thank you

the promnt from edge

  • How you installed the certificate ? your prompt look like a smartcard prompt for authentification against the IIS – yagmoth555 - GoFundMe Monica Feb 23 '17 at 13:55
  • 1
    It sounds like you have the site configured to require client certificates, which is probably not what you want. Check the SSL settings for the site and make sure it's correct and appropriate. – joeqwerty Feb 23 '17 at 14:02
  • Hi, I firstly added manually certificates to intermediate certificate authority. Then i realized i had pfx file and i ran that. After i set proper binding in my default app pool this started to happen. – Pedro Feb 23 '17 at 14:12
0

I found a problem. Out of my own stupidity I had acccept SSL certificate set to "Accept" instead of "Ignore".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.