5

I have the following problem. I just did an dvd CenOS 7 installation. After I boot into the system I normally login as the root user. From there I'm trying to configure Firewall on my server. As I'm relatively new to all of this I just did some search on how to start and manage Firewalld which seems to be the intended firewall software to use with CentOS 7. The first thing I tried was typing

systemctl status firewalld

As output I get

Warning: iptables not usable, disabling IPv4 firewall.
Warning: ip6tables not usable, disabling IPv6 firewall.
FATAL ERROR: No IPv4 and IPv6 firewall.
ERROR: Raising SystemExit in run_server

I already tried rebooting the system, updating it. I reinstalled both iptables and firewalld. Tried it with either of which being masked or disable. None of this has worked but maybe I miss something.

I generally just wanted to setup a Teamspeak server for outside use which worked under Windows when I added a specific rule to the firewall. I wanted to do the same under CentOS 7 mostly for learn purpose or to get familiar with Linux as server at all.

I'd appreciate any help.

Thank you in advance.

  • Try to use iptables-save or iptables -L to check if your kernel supports iptables. – Věroš K. Feb 24 '17 at 21:44
  • Exactly what is this "server"? – Michael Hampton Feb 24 '17 at 21:47
  • From iptables -L i get iptables v1.4.21: can't initialize iptables table 'filter' : Table does not exist (do you need to insmod?) – patvax Feb 24 '17 at 21:48
  • It is a CentOS 7 server running on a barebone x686 architecture machine. – patvax Feb 24 '17 at 21:49
0

Check your kernel version with uname -a command, If your version is below 3.10, update your kernel, reboot your system and you should be fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.