0

When I try to mount a file share in Linux VM, I use the following command:

mount -t cifs <file-share> /tffs -o vers=3.0,username=<username>,password=<key>,dir_mode=0777,file_mode=0777

The file share is in Central US. When I run this command on an Ubuntu 16.04 machine in Central US, it works fine.

When I run it on an Ubuntu 16.04 machine in South Central US, I get this:

mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

dmesg gives me this:

[  156.010050] CIFS VFS: Send error in SessSetup = -13
[  156.013201] CIFS VFS: cifs_mount failed w/return code = -13

Has anyone experienced this before? How do I get around this problem?

  • As far as I know, we can't mount file share to the VM which in another region. – Jason Ye Feb 27 '17 at 7:51
1

Note the documentation here which says:

Note

The Linux SMB client doesn’t yet support encryption, so mounting a file share from Linux still requires that the client be in the same Azure region as the file share. However, encryption support for Linux is on the roadmap of Linux developers responsible for SMB functionality. Linux distributions that support encryption in the future will be able to mount an Azure File share from anywhere as well.

Edit: There has been an update on Ububtu here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.