0

I have a Dell PowerEdge 1950 with a DRAC that I can ssh into but cannot http to. As I understand it, if the logs fill up all space, the only way to recover is to load the latest DRAC firmware. Not only can I not find the firmware, I can't find any instructions on how to update it without the web gui.

Can anyone tell me how to update an old DRAC's firmware without the GUI? I do have physical access and I am running Centos 7. I could install Windows if necessary but would rather not.

$ racadm getsysinfo

RAC Information:
RAC Date/Time           = Sat Feb 25 02:20:52 2017
Firmware Version        = 1.45
Firmware Build          = 09.01.16
Last Firmware Update    = NA
Hardware Version        = A04
Current IP Address      = 192.168.1.120
Current IP Gateway      = 192.168.1.1
Current IP Netmask      = 255.255.255.0
DHCP Enabled            = 0
MAC Address             = 00:26:b9:2f:cf:02
Current DNS Server 1    = 0.0.0.0
Current DNS Server 2    = 0.0.0.0
DNS Servers from DHCP   = 0
Register DNS RAC Name   = 0
DNS RAC Name            = rac-7CLWBG1
Current DNS Domain      = 

System Information:
System Model            = PowerEdge 1950
System Revision         = [N/A]
System BIOS Version     = 2.2.6
BMC Firmware Version    = 2.05
Service Tag             = xxxxxxxx
Host Name               = 
OS Name                 = 
Power Status            = ON

Watchdog Information:
Recovery Action         = None
Present countdown value = 15 seconds
Initial countdown value = 15 seconds
  • That's pretty ancient hardware – jordanm Feb 25 '17 at 5:50
  • Yes it is old. LOL – Tim Duncklee Feb 25 '17 at 15:03
1

Update here.

You must run the installation from with the installed CentOS system.

On newer hardware, you can install and use DSU which automates FW updates, however the 1950 is not supported so it will probably fail.

  • I tried it under Centos 7 and got the following error: Collecting inventory... /tmp/a.BIN-23222-2286/spsetup.sh: ./biosie.bin: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory Inventory collection failed. I then tried it with Centos 5.6 and got :[root@livecd sdb1]# ./Systems-Management_Firmware_D8GP9_LN32_1.65_A00.BIN Collecting inventory... ......./svm.sh: ./racsvm: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory . Inventory collection failed. – Tim Duncklee Feb 25 '17 at 15:01
  • This error message is usually related to absent 32bit-application compatibility layer on a 64bits system. see stackoverflow.com/questions/8328250/… – sfk Feb 25 '17 at 15:24
  • I got it to run with: yum install glibc.i686 compat-libstdc++-33.i686 . Now it's complaining: The DRAC update requires that virtual flash should not be in use or formated to perform the update. I did racadm racreset and racadm config -g cfgRacVirtual -o cfgVirMediaKeyEnable 0 same error. I also physically pulled the card and waited 10 min to insure a power off reset. Still same error. – Tim Duncklee Feb 25 '17 at 16:04
  • I started this because web access was not working. Somewhere along the way it started working so I unzipped the .exe version of the update and used the browser to upload the update in the payload folder and it worked. Wow. Dell did not make this easy... Thanks for your help! – Tim Duncklee Feb 25 '17 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.