2

We use Altaro VMBackup V7.0.20.3 to back up some VMs hosted on a single Hyper-V Host running Windows Server 2012 R2. One of the VMs running Windows Server 2008 gets the following error after the backup completes:

A Shadow Copy of the host was taken successfully, but an internal shadow copy by the OS running within this VM could not be taken. The backup will proceed, but the backup of this VM will be in a crash consistent state...

When I log on to the VM and run vssadmin list writers I see six writers are in State [5] - Waiting for completion, and the NTDS is state [11] Failed - Non retryable error.

In Event Viewer of the VM I see Event ID 2 saying that VSS writer NTDS failed with status 11. In addition I have an Event ID 489 sying the following:

lsass (680) An attempt to open the file "\?\Volume{b5d32627-e78e-11e4-938a-806e6f6e6963}\Windows\NTDS\ntds.dit" for read only access failed with system error 32 (0x00000020): "The process cannot access the file because it is being used by another process. ". The open file operation will fail with error -1032 (0xfffffbf8).

The VSS writers remain in that state until I reboot the VM. Then again they stay in the Stable state [1] until another backup is triggered. Now the last few days I googled on the errors and did several tests but nothing helped.

These errors occur apparently since we've migrated the VMs from a server running Windows Server 2012 (or at least we think it is since then). But all other VMs were also migrated from the old server to the new one and the Backup works.

Does anyone have any kind of information regarding these errors?

0

I am having the exact same problem, 2012R2 host with 2008 guest. The error is only happening on one guest. All other back-ups and snapshots are working.

  • I've still not found any solution for this. Please report back in case you find something. Thanks a lot – josibu Mar 12 '17 at 10:13
0

I am using the new Altaro VM backup V7 and am having the same issue with 2 domain controllers. I have found a technet post where there are 2 answers posted that have links in them that do not work. https://social.technet.microsoft.com/Forums/windows/en-US/e16d4b13-5e66-4127-a423-031140206b0d/ntdsdit-event-id489?forum=winservergen

Also contacted Altaro, They gave a workaround solution that is at least not working for my vm's. maybe this is for u:

Restart the following services: COM +Events and Volume Shadow Copy

If you try the backup now this should work. script this so that it does this at boot every time and you should be fine until Microsoft fixes this.

By the way its now 6-5-2017 all my servers are up to date, and its still not fixed.

EDIT: Just updated Altaro VM Backup to 7.2.0. did the workaround above. and its working for me now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.