1

I have a domain from GoDaddy that I'm forwarding to a heroku app. I had it set up so that in my domain "settings", forwarding with masking was set up, forwarding to the heroku app URL. In my "A" record on GoDaddy, I had the host as @ and pointing to 50.63.202.31 (GoDaddy's IP). I also have 2 CNAME records: One in which the host is * pointing to @, and another in which the host is www pointing to @.

With this setup, everything was working fine. I wanted to try to have a naked URL redirect to my site (typing in the url without the "www" wouldn't bring you to my site), so I stupidly added an extra "A" record as specified by wwwizer. Of course, this broke everything. I immediately removed that extra "A" record so everything is set up as it initially was, but I'm being brought to a completely blank page, and am getting this error message in the console: Refused to display [[[my heroku url]]] in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

My big screw up with the extra A record was about 10 hours ago. The folks at GoDaddy have told me it can take up to 48 hours for the DNS to update, and that the way I have it now (my original settings) is correct but I'm a little incredulous that it's taking this long, and worried that this is irreversible.

Is this really just a matter of the DNS taking a while to update, or have I permanently screwed things up?? Obviously I'm pretty new to this stuff, so any and all input or advice is tremendously appreciated!!

  • You do not need to remove or add anything in the DNS. I suggest you keep BOTH records of www and @ and point them to the IP where your app/site is hosted. Then you can manage Redirects via .htaccess or similar on your host – Orphans Feb 28 '17 at 7:49
0

This will stay in your and every other persons DNS cache until the TTL of the record is reached. You can set this TTL yourself. Furthermore, the change has to propagate through godaddys DNS servers, which might take additional time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.