0

I have just tried to setup subversion on a new server.

The connection is being made via an SSH tunnel but isn't getting through, I suspect from a few bad login attempts, although I'm not sure there were 6.

I can still login as root via SSH normally:

 19:53:30 xxxx sshd[32281]: Accepted publickey for root from xxxx port 55731 ssh2: RSA xxxxx
Feb 28 19:53:30 xxxx sshd[32281]: pam_unix(sshd:session): session opened for user root by (uid=0)

But get this error in the logs for the attempts via my SVN client

Feb 28 19:54:06 xxxx sshd[32306]: Connection closed by xxxxxx [preauth]

Also in the logs is:

Feb 28 19:43:25 xxxx sshd[32187]: Disconnecting: Too many authentication failures for root [preauth]

Which seems to confirm my suspicions, although I have changed the allowed number of failed logins in sshd_config to a large number which has not helped.

Also pamtally2 has no bad logins:

pam_tally2 -u root
Login           Failures Latest failure     From
root                0 

So it doesn't look like root is being blocked yet root can't login via SSH from the SVN client. The SVN client is connecting to all other servers correctly, they all use the same public key.

Is there some other way to reset a bad login tally?

Edit - here are the result with verbose logging turned on:

Feb 28 23:24:43 xxxx sshd[2551]: Set /proc/self/oom_score_adj to 0
Feb 28 23:24:43 xxxx sshd[2551]: Connection from xxxx port 50384 on xxxx port 22
Feb 28 23:24:44 xxxx sshd[2551]: Found matching RSA key: xxxxx
Feb 28 23:24:44 xxxx sshd[2551]: Postponed publickey for root from xxxx port 50384 ssh2 [preauth]
Feb 28 23:24:45 xxxx sshd[2551]: Connection closed by xxxx [preauth]
  • Can you make subversion do the ssh with -v -v -v and then view those verbose logs? – thrig Feb 28 '17 at 22:45
  • My client builds the connection from some limited inputs so I can't do that – Kline Feb 28 '17 at 23:21
  • I have turned on verbose logging in sshd_config and posted the results in my question, not sure it helps unfortunately. – Kline Feb 28 '17 at 23:30
  • 1. If you login as root, you are on the wrong path 2. If you have configured server with (your OS here) according to well-known "SVN+SSH HowTo" manuals (not with posts from nameless bloggers) you have to have no problems 3. Show you config and all performed operations step-by-step – Lazy Badger Mar 1 '17 at 4:50
  • any SVN-client (or client's OS) must to provide publickey (this is client and OS-specific procedure) on request. Did you do it? – Lazy Badger Mar 1 '17 at 4:54
0

This turned out to be an issue with the client upgrading it or using another client worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.