1

I am new to pfSense. I purchased two Netgate devices: SG-1000 and SG-2220.

First, I setup both with DHCP on WAN interfaces. Everything worked as expected (both on internal interface of existing router and connected to a cable ISP with DHCP).

Then I setup the SG-2220 with a static IP from our ISP that provides static IP's. While not our actual settings, this illustrates our settings:

IP: 66.102.66.60
Subnet: 255.255.255.248 (29)
Gateway: 66.102.66.57

All worked as expected.

Using the exactly the same settings, the SG-1000 will not connect on the WAN.

Attempts at resolution:

  1. Re-enter settings.
  2. Reboot device.
  3. Reboot device and client PC.
  4. Factory reset.
  5. Set WAN back to DHCP and connected via old router to confirm working NIC in SG-1000.
  6. Connected PC directly and used WAN settings. Worked as expected.
  7. Changed cables.

I am at a loss of how to proceed.

Any suggestions welcome.

Additional information:

Packet capture from problem device: SG-1000

Packet capture from working device: SG-2440

Additional information:

The SG-1000 will connect to the ISP gateway router only if connected through a switch. Love to know why.

  • Did you power-cycle your modem before connecting the SG-1000? Most cable modems are notoriously picky router MAC addresses, and need to be rebooted when routers change. – EEAA Feb 28 '17 at 21:25
  • Hey thank you for suggestion. Yes, forgot to mention I power cycled the Catalyst 2950 (the ISP's provided router). I also used the MAC spoofing in the SG-1000 with the MAC from the SG-2220 in case this was the issue. – Weehooey Feb 28 '17 at 21:28
  • Added to list: updated the firmware to most recent. – Weehooey Feb 28 '17 at 22:22
  • I have swapped the interfaces to confirm hardware is working as expected. Multiple other devices have been connected with the same configuration. Also applied the latest firmware update. The SG-1000 refused to connect to our ISP with a static IP address. – Weehooey Mar 22 '17 at 19:32
  • Are there any logs you can get out of those boxes? – duenni Mar 22 '17 at 19:41
0

It appears the SG-1000 has a known (not well known but known) issue with ports that are not set to autonegotiation (autoneg).

The Cisco switch was set to 10Mbps Full Duplex and even if the SG-1000 was set to the same, it would not properly establish TCP traffic.

We had the ISP change the ports on the switch to autoneg and the SG-1000 worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.