2

I have a small topology of virtualized machines (one PFSense Firewall and a Windows 7 box for testing connectivity).

The host has two bridge interfaces configured

br0 connects the host WAN (eno3) and PFSense WAN (xn0). This provides the internet connectivity for both hosts. I can successfully connect to both from the outside.

br1 connects the PFSense LAN (xn1) to the virtual adapters of the other guests (Windows 7 for this case).

My problem is that for whatever reason I cannot get hosts inside br1 to ping each other. If I add an address to br1 from the host I am able to send and receive pings to both guest's IP addresses and they can ping the host address. In checking Wireshark I can see the two hosts broadcasting ARP to find the other machine. Wireshark capture from br1

but does not ever turn into a successful ping. I've tried disabling the firewall on the Windows 7 client but it still does not work.

7
  • Which Ethernet drivers are you using on both guest systems? I had a similar issue while using the VirtIO drivers and I have switched it to the e1000e driver (Intel) in order to resolve
    – DarkVex
    Mar 3 '17 at 21:30
  • I was using the rtl8139, I'll try the e1000e drivers. Mar 3 '17 at 21:36
  • Still getting the same issue with the e1000e drivers Mar 3 '17 at 21:43
  • Oh, actually I just tried for the heck of it to create a new host and when I checked if it had got an address it worked. It received the local IPv4 and global IPv6 address from pfsense. Awesome! I say setting the e100e drivers worked then. Mar 3 '17 at 21:50
  • Ok, I'll make my previous reply as an answer, so you can vote it :)
    – DarkVex
    Mar 3 '17 at 21:52
1

I had experience similar issue while using the VirtIO drivers. I have changed all the guest systems Ethernet drivers to e1000e in order to solve it.

4
  • This is as misleading as it can possibly be. There is no correlation between the NIC type and network connectivity, unless you were using some buggy version of qemu or the virtio drivers.
    – dyasny
    Mar 5 '17 at 2:13
  • yep, but on Ubuntu 16.04 it seems the virtio drivers have some bugs (I didn't tried with the last Ubuntu updates if still happens)
    – DarkVex
    Mar 5 '17 at 12:06
  • 2
    And this is exactly why you avoid Ubuntu for anything serious like virtualization
    – dyasny
    Mar 5 '17 at 15:51
  • I completely agree with you! In fact on my server I have a RHEL based hypervisor and I never had this kind of issue.. I can't tell the same for the workstation at work with Ubuntu. After a lot of fighting I had the chance of installing Fedora
    – DarkVex
    Mar 5 '17 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.