The server is ubuntu 16.04. I can login vsftpd as the following:

ftp> open MY_FTP_IP
Connected to MY_FTP_IP.
220 (vsFTPd 3.0.3)
Name (MY_FTP_IP:ACCOUNT_NAME): someftpuser

The problem is that ACCOUNT_NAME is my sudoers's name, and I don't want the ftp user to see it. How do I change or remove that ACCOUNT_NAME?


You can use the following ftp flag:

ftp -n

-n - Restrains ftp from attempting ''auto-login'' upon initial connection.

If auto-login is enabled, ftp will check the .netrc (see netrc(5)) file in the user's home directory for an entry describing an account on the remote machine. If no entry exists, ftp will prompt for the remote machine login name (default is the user identity on the local machine), and, if necessary, prompt for a password and an account with which to login.

More info in ftp man page

In your case execute to following command:

ftp -n MY_FTP_IP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.