2

Recently updated from windows 7 enterprise to windows 10 enterprise and went to run a script that has a call to Get-GPPermision and it errored out as missing that command. Edit: Set-GPPermission is also missing.

checking for commands inside the group policy cmdlet shows that yes it is missing:

PS C:\WINDOWS\system32> get-command -Module grouppolicy

CommandType     Name                                               Version    Source                                             
-----------     ----                                               -------    ------                                             
Cmdlet          Backup-GPO                                         1.0.0.0    GroupPolicy                                        
Cmdlet          Copy-GPO                                           1.0.0.0    GroupPolicy                                        
Cmdlet          Get-GPInheritance                                  1.0.0.0    GroupPolicy                                        
Cmdlet          Get-GPO                                            1.0.0.0    GroupPolicy                                        
Cmdlet          Get-GPOReport                                      1.0.0.0    GroupPolicy                                        
Cmdlet          Get-GPPrefRegistryValue                            1.0.0.0    GroupPolicy                                        
Cmdlet          Get-GPRegistryValue                                1.0.0.0    GroupPolicy                                        
Cmdlet          Get-GPResultantSetOfPolicy                         1.0.0.0    GroupPolicy                                        
Cmdlet          Get-GPStarterGPO                                   1.0.0.0    GroupPolicy                                        
Cmdlet          Import-GPO                                         1.0.0.0    GroupPolicy                                        
Cmdlet          New-GPLink                                         1.0.0.0    GroupPolicy                                        
Cmdlet          New-GPO                                            1.0.0.0    GroupPolicy                                        
Cmdlet          New-GPStarterGPO                                   1.0.0.0    GroupPolicy                                        
Cmdlet          Remove-GPLink                                      1.0.0.0    GroupPolicy                                        
Cmdlet          Remove-GPO                                         1.0.0.0    GroupPolicy                                        
Cmdlet          Remove-GPPrefRegistryValue                         1.0.0.0    GroupPolicy                                        
Cmdlet          Remove-GPRegistryValue                             1.0.0.0    GroupPolicy                                        
Cmdlet          Rename-GPO                                         1.0.0.0    GroupPolicy                                        
Cmdlet          Restore-GPO                                        1.0.0.0    GroupPolicy                                        
Cmdlet          Set-GPInheritance                                  1.0.0.0    GroupPolicy                                        
Cmdlet          Set-GPLink                                         1.0.0.0    GroupPolicy                                        
Cmdlet          Set-GPPrefRegistryValue                            1.0.0.0    GroupPolicy                                        
Cmdlet          Set-GPRegistryValue                                1.0.0.0    GroupPolicy      

Here's the version table:

PS C:\WINDOWS\system32> $PSVersionTable

Name                           Value                                                                                             
----                           -----                                                                                             
PSVersion                      5.1.14393.693                                                                                     
PSEdition                      Desktop                                                                                           
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}                                                                           
BuildVersion                   10.0.14393.693                                                                                    
CLRVersion                     4.0.30319.42000                                                                                   
WSManStackVersion              3.0                                                                                               
PSRemotingProtocolVersion      2.3                                                                                               
SerializationVersion           1.1.0.1

The latest (posted last month) I can find shows the command stil there: https://technet.microsoft.com/itpro/powershell/windows/group-policy/index

Note: it appears that Microsoft has broken backwards compatibility since the calls were named Get-GPPermissions and Set-GPPermissions in group policy with powershell 4, now they droped the 's' and are both named singular Get-GPPermission and Set-GPPermission.

Anyone know how I can re-install the module?

Edit: module re-install was easy it was just a case of uninstalling RSAT and then re-installing that. Sadly the command is still not showing up so my question should now be how to regain the missing commands.

8
  • 1
    What build of Windows 10 are you using? It might be a Build 1607 thing.
    – Zoredache
    Mar 6 '17 at 22:15
  • It's version 1607 (OS build 14393.693). So what is a "Build 1607 thing"?
    – sdjuan
    Mar 6 '17 at 22:22
  • OK I read about 1607 issuesnow but they seem like last year's thing. Still happening huh? A bit disappointing with "enterprise software" I use powershell a lot for admin. Guess I'll have to go back to win 7 to use that group policy command. If there's a way you can demonstrate that it is a 1607 issue put it as an answer and I'll accept it.
    – sdjuan
    Mar 6 '17 at 22:33
  • What? I meant that I didn't think that commandlet existed until 1607. You say you have it on Windows 7? You mention 'upgrade'/ Surely you meant clean install with Windows 10? Are you sure you have the newest version of RSAT installed?
    – Zoredache
    Mar 6 '17 at 22:36
  • My fellow sysadmin created an SCCM upgrade package for win 7 --> win 10 and I used that on my workstation (after testing on a nother system) and it just worked. I was using get-gppermissions since 2014 on windows 7 to check when some of us folks forget to give the group edit permissions on GPOs. I'll need to check about the RSAT version and get back here. OK RSAT is what I downloaded 2/28/2017 and says build is RSAT-WS2015-x64
    – sdjuan
    Mar 6 '17 at 22:43
0

After spending too many hours trying to debug this I gave up and re-imaged the system from scratch which fixed the issue. It's not an answer but it makes the question moot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.