0

Trying to configure switching on Mikrotik CRS125-24-1S.

  • ether24 is connected to another switch port with tag all (trunk) mode activated
  • ether23 is connected to my ESXi host

I just want to add this Mikrotik switch in the middle of the network path, no routing is needed. One example VLAN is 13.

I've tried adding the VLAN:

Flags: X - disabled, I - invalid, D - dynamic 
 #   VLAN-ID PORTS                                       SVL LEARN FLOOD INGRESS-MIRROR QOS-GROUP                                     
 0 D    4095 ether1                                      no  no    no    no             none                                          
             ether2                                     
             ether3                                     
             ether4                                     
             ether5                                     
             ether6                                     
             ether7                                     
             ether8                                     
             ether9                                     
             ether10                                    
             ether11                                    
             ether12                                    
             ether13                                    
             ether14                                    
             ether15                                    
             ether16                                    
             ether17                                    
             ether18                                    
             ether19                                    
             ether20                                    
             ether21                                    
             ether22                                    
             sfp1                                       
             switch1-cpu                                
 1        13 ether23                                     no  yes   no    no             none                                          
             ether24                                    
             switch1-cpu                                

Also the egress vlan tag:

[admin@MikroTik] /interface ethernet switch egress-vlan-tag> print
Flags: X - disabled, I - invalid, D - dynamic 
 #   VLAN-ID TAGGED-PORTS                                                                                                            
 0 D    4095
 1        13 ether23                                                                                                                 
             ether24                                                                                                                 
             switch1-cpu                                                             

The terms on RouterOS are somehow different, I know I'm missing something. Don't know what.

But communication is not happening. I know routing is working because right now I have a Cisco Switch to test and doing that on Cisco works well.

Thanks

0

No need VLAN adding. Just create a bridge and attach ports 23 and 24 to that bridge. All traffic including tagged one will pass.

/interface bridge add name=bridge-trunk protocol=none
/interface bridge port add bridge=bridge-trunk interface=ether23
/interface bridge port add bridge=bridge-trunk interface=ether24

OR/If you have performance issues (CRS125 CPU going up when several 100'Mbps are passing), you can use the inboard switch chip, faster than bridge.

/interface ethernet set [ find name=ether24 ] master-port=ether23

Then eth24 will be enslaved to eth23 and the two ports will act like a simple switch.

If it does not work, just reset-config the CRS125 with "no-default" option to wipe out all messy config and re-do the previous commands.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.