I am currently trying to install FreeNAS 9.10.2 on Dell PowerEdge R710.

I am running FreeNAS off a usb which is loading fine.

I select FreeNAS in the GRUB menu by hitting enter. Once I am in the FreeNAS console setup screen, my keyboard does not work anymore. It is a usb keyboard and I don't have a PS/2 port to use as an alternative.

Any suggestions?


It actually happened to me too, but on different machine (PE2900 III). So I would try to check the iso hash count and burn the image on DVD and use usb DVD drive to install the OS- worked for me. I also have used USB keyboard.

  • The Dell Power Edge does have a SATA CD drive included but I ran into the same problem when trying to install FreeNAS via a CD. – Scott Roriston Mar 15 '17 at 6:56

I imagine this has to do with how USB is configured in the BIOS/UEFI. Make sure to enable legacy USB devices, or USB 1.1 emulation. This will make the firmware handle the keyboard, rather than passing control to your OS - and FreeNAS might not work with some of the more "exotic" keyboards unless the firmware is handling that I/O for it. Finally, if that doesn't work, try a different (simpler) USB keyboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.