0

I have installed TigerVNC on my DigitalOcean FE24 box following https://docs.fedoraproject.org/en-US/Fedora/21/html/System_Administrators_Guide/ch-TigerVNC.html.

I start my vnc server with the command

$ systemctl start vncserver@:0.service
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'vncserver@:0.service'.
Authenticating as: user
Password:
==== AUTHENTICATION COMPLETE ===
Job for vncserver@:0.service failed because a timeout was exceeded. See "systemctl status vncserver@:0.service" and "journalctl -xe" for details.

This keeps happening after hardly a minute I run the command and the VNC access is lost.

Where am I going wrong?

1

Editing the file /etc/systemd/system/vncserver@.service solved it for me, specifically by removing the following lines:

ExecStartPre=-/usr/bin/vncserver -kill %i

PIDFile=/home/<USER>/.vnc/%H%i.pid

I had this exact problem, which also was causing the service to fail on boot (when it was enabled via systemctl enable vncserver@:0.service. Starting the service manually (via systemctl start vncserver@:0.service) would disconnect connected VNC clients after about a minute or so.

I happened upon the answer in this thread via fedoraforum.org, so credits to them!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.