0

So here's an interesting problem that just started happening today. OWA is no longer working on the internal network or Externally. I now get an error in IE saying:

"Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://server again. If this error persists, it is possible that this site uses an unsupported protocol or cipher suite such as RC4 (link for the details), which is not considered secure. Please contact your site administrator. "

Yet in IE, TLS is enabled and SSL 2 & 3 have been disabled. I used IISCrypto on my Exchange 2010 server and it shows I am running with best practices.

I've also tried rebuilding my OWA Virtual Directory with no success.

I don't see any obvious errors in Event Viewer.

What could I be missing?

Another note, email is being forwarded to my exchange box from my mailmarshall server but external email is not showing in mailboxes. Only internal emails are.

  • Use something like bolet.org/TestSSLServer to double check whether the expected SSL/TLS versions are being used by the server. Are they as expected? – bao7uo Mar 10 '17 at 18:33
0

Exchange rarely does anything on its own - so if it has only happened today - what has changed? Something will be logged.

Is this a single server of multiple? How did you rebuild the virtual directory? Can you browse to the root of the site? If not, then the issue is probably with IIS rather than Exchange. Check the correct bindings are in place on the default web site.

| improve this answer | |
  • I've found errors in Symantec Mail Security. As soon as I started an uninstall of that, outside emails came in. Still no OWA access yet though. Other than that, nothing has changed config wise on the server. – FLAdmin Mar 10 '17 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.