0

I'm trying to set up network scanning on a newer Fedora Core 24 machine and all the guides I've been able to find seem to be a bit outdated (Fedora Core 10/14). They talk about setting up a xinetd socket file, and while the folders still present in /etc there are no other signs that xinetd still runs.

So far, I'm not seeing any indications that the server is listening on the correct port for sane (checked using netstat) with the xinet config file setup and I'm strongly suspecting I need to set up the listening socket differently to get a result.

How should I configure sane to listen on the network for requests under Fedora Core 24?

0

Ok, so it turns out what I needed to do was define the same socket / daemon information for systemd using a .socket and a .service unit file. The files I've created contain the following contents:

sane.socket

[Unit]
Description=saned incoming socket

[Socket]
ListenStream=6566
Accept=yes
MaxConnections=1

[Install]
WantedBy=sockets.target

saned@.service

[Unit]
Description=Scanner Service
Requires=saned.socket

[Service]
ExecStart=/usr/sbin/saned
User=saned
Group=saned
StandardInput=null
StandardOutput=syslog
StandardError=syslog

After creating these definition files in /usr/lib/systemd/system all that was needed was:

systemctl enable saned.socket
systemctl start saned.socket

And now I can access the scanner via the network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.