One and only working logon server in the domain. When I run DCDIAG, it returns:

Starting test: NetLogons
* Network Logons Privileges Check
Unable to connect to the NETLOGON share! (\SBS08-DC\netlogon) [SBS08-DC] An net use or LsaPolicy operation failed with error 1203, The network path was either typed incorrectly, does not exist, or the network provider is not currently available. Please try retyping the path or contact your network administrator........................... SBS08-DC failed test NetLogons

There are no recent backups that contain the NETLOGON folder that I can find, and this is the only working logon server. I have tried to recreate the NETLOGON folder by setting registry key HKEY_Local_Machine\System\CurrentControlSet\Services\Netlogon\Parameters SysVolReady=1, SysVolReady0, then rebooting, but it did not work.

As I said, the other DC does not work as a logon server, so I cannot replicate NETLOGON from it (it too does not have one). Lastly, I cannot yet move FSMO's away from the SBS 08 DC since it also run Exchange. What are my options here? Thank you.

1 Answer 1


Here's what I did and it seems to have worked, but please tell me if this was not the best route:

  • On the only working logon server (SBS 08), C:\Windows\Sysvol\Domain\Scripts folder did not exist. As such, the NETLOGON subfolder also did not exist.
  • I google'd to find what the Share and NTFS permissions of NETLOGON should be.
  • I stopped the File Replication Service on SBS 08 DC.
  • I manually created a NETLOGON in the correct location on the SBS 08 DC, then made sure Share and NTFS permissions were set correctly.
  • I restarted the File Replication Service on SBS 08 DC and sure enough, it replicated the Scripts\NETLOGON out to both Svr 2012 R2 DC2 and DC3.
  • However, it did not create them as shares, so I manually set \%LogonServer%\NETLOGON to be shared with read rights for everyone on Sv2 2012R2 DC2 and DC3.
  • I then re-ran DCDIAG on all three DC's and all three passed!
  • I shutdown SBS 08 DC and sure enough, Svr 2012R2 DC2 logged in 3 test client PC's!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .