1

I manage Raid 1 with LSI Controller ( SAS9211-8i ). Recently one of the Hard drives failed, I replaced it and booted the machine, Entered the LSI utility, and I noticed it's 'Rebuilding' and syncing the raid. But, after about 30% of syncing, I received 'Failed' status over the 'Rebuilding' on the new hard drive. I also tried to replace the new hard drive with a different new one, Same error.

Picture: http://i.imgur.com/FDvIQ2h.jpg

I have no clue why is it Failing all the time. and because the raid 1 is in status 'Degraded', My OS booting as 'read-only' mode and won't function properly.

Thanks a lot for the help!

  • As a quick troubleshooting step, try to plug the new drive in another slot than the original one. – batistuta09 Mar 13 '17 at 10:36
  • Hi, I don't have another free slot, All the other slots are used for software raid by OMV system. – Shlomi Mar 13 '17 at 12:25
  • Have you thought about checking the single still working drive for the errors (chkdsk)? – batistuta09 Mar 13 '17 at 19:35
2

It is likely the other disk has issues as well which is causing the rebuild to fail. I would suggest the first thing to do is to try to create a disk image from the existing disk. It's best to use a cdrom or usb stick to boot knoppix or something.

Then assuming the drive is located at /dev/sda and you have space available on a different (USB mounted) drive mounted at /mnt/data run something like:

dd bs=200M conv=noerror if=/dev/sda of=/mnt/data/sda.img

I use bs=200M to speed up the copy, it will copy 200MB chunks at once, I use conv=noerror to allow dd to continue if it finds a disk error. See the dd man page for more information.

If you want to use ssh to copy the image over while it is created see: https://unix.stackexchange.com/questions/132797/how-to-dd-a-remote-disk-using-ssh-on-local-machine-and-save-to-a-local-disk

If dd is not working and throws too many errors the disk is close to being unsalvagable and you want to try ddrescue or something: https://help.ubuntu.com/community/DataRecovery#Imaging_a_damaged_device.2C_filesystem_or_drive

To create a bootable disk out of that image find a disk of equal or bigger size and connect it through USB for example. Let's say the new disk is at /dev/sdd:

dd bs=200M conv=noerror if=/mnt/data/sda.img of=/dev/sdd

Once done, shut down the system and replace the existing raid disk with the new one and boot the system to see whether it boots. You may have to (re)-configure the raid controller, not sure. It may boot into read-only mode again, since the raid is still degraded.

Now insert another disk and allow the raid to rebuild. It may now finish successfully. It is possible the raid controller will see the disk as a JBOD and you will need to add it again into a raid before you can have a fully working raid1.

| improve this answer | |
  • 2
    I would strongly recommend the use of ddrescue first. You only get a finite amount of opportunities to grab intact data from a failing drive, which this one probably is. – Spooler Mar 17 '17 at 1:30
  • Not a bad idea at all :-) – aseq Mar 17 '17 at 2:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.