1

I am having a problem i cannot install roles or features at all.

I installed windows server 2016 standard with desktop as a hardware machine not virtual joined existing domain installed anti-virus software a few tools then i added active directory role promoted to domain controller then made it the primary controller.

I noticed that windows server backup was not installed by default and tried to add it. It failed using both GUI wizard and with PS i also tried to add IIS server role with GUI and get the same error this is the output from PS ive tried using the -source switch leading to the dell install DVD and the error doesn't change been searching internet for a week not much information out there on server 2016 any help would be appreciated

PS C:\Users\Administrator.MOSBAUGH> install-windowsfeature -name windows-server-backup
install-windowsfeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The referenced assembly could not be found. Error: 0x80073701
At line:1 char:1
+ install-windowsfeature -name windows-server-backup
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo         : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
    Exception
    + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
  owsFeatureCommand

Success Restart Needed Exit Code     Feature Result
------- -------------- ---------     --------------
False No           Failed       {}

here are the logs

2017-03-16 08:25:19, Info CBS Exec: 1 deployments need bulk staging 2017-03-16 08:25:19, Error CSI 00000008@2017/3/16:15:25:19.195 (F) onecore\base\wcp\componentstore\csd_locking.cpp(200): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null) [gle=0x80004005] 2017-03-16 08:25:19, Info CBS Added C:\Windows\Logs\CBS\CBS.log to WER report. 2017-03-16 08:25:19, Info CBS Added C:\Windows\Logs\CBS\CbsPersist_20170316151828.log to WER report. 2017-03-16 08:25:19, Info CBS Added C:\Windows\Logs\CBS\CbsPersist_20170316143828.log to WER report. 2017-03-16 08:25:19, Info CBS Added C:\Windows\Logs\CBS\CbsPersist_20170316135830.log to WER report. 2017-03-16 08:25:19, Info CBS Added C:\Windows\Logs\CBS\CbsPersist_20170316131828.log to WER report. 2017-03-16 08:25:19, Info CBS Added C:\Windows\Logs\CBS\CbsPersist_20170316123827.log to WER report. 2017-03-16 08:25:19, Info CBS Not able to add pending.xml to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND] 2017-03-16 08:25:19, Info CBS Not able to add pending.xml.bad to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND] 2017-03-16 08:25:19, Info CBS Not able to add poqexec.log to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND] 2017-03-16 08:25:19, Error CSI 00000009 (F) STATUS_SXS_ASSEMBLY_MISSING #1938# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c] 2017-03-16 08:25:19, Error CSI 0000000a (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #1786# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = Microsoft-Windows-BLB-Deployment-LanguagePack, version 10.0.14393.0, arch amd64, culture [l:5]'de-DE', nonSxS, pkt {l:8 b:31bf3856ad364e35}, cb = (null), s = (null), rid = 'Microsoft-Windows-BLB-Package~31bf3856ad364e35~amd64~de-DE~10.0.14393.0.WindowsServerBackup', rah = (null), manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701] 2017-03-16 08:25:19, Info CBS Failed to pin deployment while resolving Update: Microsoft-Windows-BLB-Package~31bf3856ad364e35~amd64~de-DE~10.0.14393.0.WindowsServerBackup from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING] 2017-03-16 08:25:19, Info CBS Failed to bulk stage deployment manifest and pin deployment for package:Microsoft-Windows-BLB-Package~31bf3856ad364e35~amd64~fr-FR~10.0.14393.0 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING] 2017-03-16 08:25:19, Info CBS CommitPackagesState: Started persisting state of packages 2017-03-16 08:25:19, Info CBS CommitPackagesState: Completed persisting state of packages 2017-03-16 08:25:19, Info CSI 0000000b@2017/3/16:15:25:19.305 CSI Transaction @0x27e7fd8feb0 destroyed 2017-03-16 08:25:19, Info CBS Perf: Resolve chain complete. 2017-03-16 08:25:19, Info CBS Failed to resolve execution chain. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING] 2017-03-16 08:25:19, Error CBS Failed to process single phase execution. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING] 2017-03-16 08:25:19, Info CBS WER: Generating failure report for package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.14393.0, status: 0x80073701, failure source: Resolve, start state: Installed, target state: Installed, client id: DISM Package Manager Provider

2017-03-16 08:25:14, Info DISM DISM Provider Store: PID=9420 TID=8584 Provider has not previously been encountered. Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider 2017-03-16 08:25:14, Info DISM DISM Provider Store: PID=9420 TID=8584 Loading Provider from location C:\Windows\TEMP\9635013C-AFB3-4CA4-A413-6716C64C4A10\CbsProvider.dll - CDISMProviderStore::Internal_GetProvider 2017-03-16 08:25:14, Info DISM DISM Provider Store: PID=9420 TID=8584 Connecting to the provider located at C:\Windows\TEMP\9635013C-AFB3-4CA4-A413-6716C64C4A10\CbsProvider.dll. - CDISMProviderStore::Internal_LoadProvider 2017-03-16 08:25:14, Info DISM DISM Provider Store: PID=9420 TID=8584 Encountered a servicing provider, performing additional servicing initializations. - CDISMProviderStore::Internal_LoadProvider 2017-03-16 08:25:15, Info DISM DISM Package Manager: PID=9420 TID=8584 Finished initializing the CbsConUI Handler. - CCbsConUIHandler::Initialize 2017-03-16 08:25:15, Info DISM DISM Package Manager: PID=9420 TID=8584 CBS is being initialized for online use. More information about CBS actions can be located at: %windir%\logs\cbs\cbs.log - CDISMPackageManager::Initialize 2017-03-16 08:25:15, Info DISM DISM Package Manager: PID=9420 TID=8584 Loaded servicing stack for online use only. - CDISMPackageManager::RefreshInstanceAndLock 2017-03-16 08:25:16, Info DISM DISM Package Manager: PID=9420 TID=8584 Initiating Changes on Package with values: 5, 7 - CDISMPackage::Internal_ChangePackageState 2017-03-16 08:25:18, Info DISM DISM Package Manager: PID=9420 TID=8584 CBS session options=0x40100! - CDISMPackageManager::Internal_Finalize 2017-03-16 08:25:19, Info DISM DISM Package Manager: PID=9420 TID=8012 Error in operation: (null) (CBS HRESULT=0x80073701) - CCbsConUIHandler::Error 2017-03-16 08:25:19, Error DISM DISM Package Manager: PID=9420 TID=8584 Failed finalizing changes. - CDISMPackageManager::Internal_Finalize(hr:0x80073701) 2017-03-16 08:25:19, Error DISM DISM Package Manager: PID=9420 TID=8584 Failed processing package changes with session options - CDISMPackageManager::ProcessChangesWithOptions(hr:0x80073701) 2017-03-16 08:25:19, Error DISM API: PID=3560 TID=1232 Failed to process features change - CEnableDisableFeatureCommandObject::InternalExecute(hr:0x80073701) 2017-03-16 08:25:19, Error DISM API: PID=3560 TID=1232 InternalExecute failed - CBaseCommandObject::Execute(hr:0x80073701) 2017-03-16 08:25:19, Error DISM API: PID=3560 TID=9896 CEnableDisableFeatureCommandObject internal execution failed - DismEnableDisableFeatureInternal(hr:0x80073701) 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Exit DismEnableDisableFeatureInternal - DismEnableDisableFeatureInternal 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Enter DismGetLastErrorMessageInternal - DismGetLastErrorMessageInternal 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Exit DismGetLastErrorMessageInternal - DismGetLastErrorMessageInternal 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Enter DismDeleteInternal - DismDeleteInternal 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Leave DismDeleteInternal - DismDeleteInternal 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Enter DismCloseSessionInternal - DismCloseSessionInternal 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Input parameters: Session: 2 - DismCloseSessionInternal 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 GetReferenceCount hr: 0x0 - CSessionTable::RemoveSession 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Refcount for DismSession= 2s 0 - CSessionTable::RemoveSession 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=9896 Successfully enqueued command object - CCommandThread::EnqueueCommandObject 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=1232 ExecuteLoop: CommandQueue signaled - CCommandThread::ExecuteLoop 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=1232 Successfully dequeued command object - CCommandThread::DequeueCommandObject 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=1232 ExecuteLoop: Cancel signaled - CCommandThread::ExecuteLoop 2017-03-16 08:25:19, Info DISM API: PID=3560 TID=1232 Leave CCommandThread::ExecuteLoop - CCommandThread::ExecuteLoop

Also it did updates yesterday they worked except for KB4013429 but it says the system is up to date

  • 1
    That's one I haven't seen before. Go to %windir%\logs, and search in both cbs\cbs.log and dism\dism.log for ", error" (a comma space error) and add the most recent ones to your post, and 10 to 15 lines before and after. – Matthew Wetmore Mar 16 '17 at 5:39
  • @Mitch I know this is a silly question but is your Windows Update service running? It looks like it is reaching out to pull in some updates which it uses for installation just like back in Server 2008 days where it downloaded the installer for WSUS. Also did you try an sfc /scannow ? – JukEboX Aug 23 '17 at 21:55
  • That happend for me too few months ago. I installed NPS on my Server 2016 and made reboot. After reboot I wasn't able to install any roles and features via GUI nor PowerShell and it got more stanger cause few roles and features was missing from the list. On top of that Server Manager didn't even detect that AD DS was running on this virtual machine but manually checking AD/DNS resulted in successful output. I didn't got time debug issue in depth so I ended up just reinstalling Server 2016. – Gen Jan 1 '18 at 11:11
1

i had to remove all reference values not keys containing fr-FR and de-DE values from the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect] and i am now able to add roles and features neither of the language packs were installed on the server.

  • Micth, How did you find the references to the languages ​in that option? To delete all. Please. I have the same problem. Install-windowsfeature : The request to add or remove features on the specified server failed. Installation of one or more roles, role services, or features failed. The referenced assembly could not be found. Error: 0x80073701 At line:1 char:1 + Install-windowsfeature AD-Domain-Services + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature], Exception + FullyQualifiedErrorId : DISMA – celisam Aug 23 '17 at 21:29
1

Finally it fixed! Here's how:

  • Run C:\Windows\System32\lpksetup.exe
  • Chose "Uninstall"
  • Uninstall (nearly) all displayed languages (eg French, German, Korean, Japanese)
  • This will take a while

After uninstalling those additional languages, open the Server Manager again, click the Roles & Features wizard and install the telnet feature. This doesn't require any registry editing and server restart.

New contributor
Ritesh Srivastava is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

I was able to fix this as follows:

I had the same experience with a new Dell server, loaded with Server 2016 with English, Japanese, French, Spanish, and Korean languages pre-installed.

Something went south and the language pack for Korean was not installed. But the OS registry entries in [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect] were created and orphaned.

When I tried to install some roles or features the error "The referenced assembly could not be found." was returned due to the install looking for those referenced language entries that were not installed.

If you open powershell and run lpksetup, click on uninstall display languages and see which languages are installed. I uninstalled all extra languages, one at a time.

Now you can try the install and when it fails goto c:\windows\logs\cbs. Throw the CBS log into notepad and search for the text error. Look for a line with "error CSI 0000000a (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) ", the next line with say "Info CBS Failed to pin deployment while resolving Update:" and might have the name of the package that is missing.

If your luck it will have a language code EN, ES, ko-KR, etc...

That's the language package that has been orphaned!

Now the fun part you can 1. Delete all the entries in the registry, alot of them! or 2. Download the language pack or language pack ISO for 2016 server and install the language pack for the offending language using the lpksetup utility and the cab for the language. Then using lpksetup again to remove the language.

Done!

Try your role or feature install again.

This is how I ended up fixing the problem.

Took me a while to find the proper language pack for Server 2016, the windows 10 packs no work-y... Had to down load an ISO from the Microsoft licensing site to get the correct one!

Hope this helps someone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.