0

My company is using a pfsense router to manage a simple VPN for the office. The idea is that I should be able to connect to the VPN from home and use it to (a) access servers on the office LAN and (b) visit our AWS-based webservers over ports 22 and 80 via the VPN.

Unfortunately, it's currently setup as an all-or-nothing deal: if I connect to the office VPN, all of my web traffic goes through there, and I'd rather not do that.

I'm running GNOME 3.22.2 with NetworkManager and the OpenVPN plugin on Gentoo Linux, so help with these tools in mind would be appreciated.

5
  • I'm voting to close this question as off-topic because it should be addressed to your IT department. There's likely a reason that have things configured as they are.
    – EEAA
    Mar 16 '17 at 11:16
  • My company is 8 people and the office bandwidth is limited. We're just trying to limit superfluous traffic from going through the office.I'm the most senior IT person at the company, but I'm a web developer. I'm not trying to circumvent anything, but rather help my company do exactly what the CEO has asked. Mar 16 '17 at 11:57
  • If this is something that can't be solved on the client, then by all means, suggest how I might fix this on the server. It seems silly to infer that I'm somehow trying to get around security simply by asking a question. Mar 16 '17 at 11:59
  • I've re-opened the question. We get a many questions like this, phrased similar to how yours was, where people are trying to get around IT department restrictions. You gave no indication that you had control of or knew anything about how the VPN was configured, so I closed the question.
    – EEAA
    Mar 16 '17 at 12:34
  • I don't have time to give a proper answer right now, but check your server config for a redirect-gateway line. Remove that and it should stop sending all of your traffic through the VPN. One additional item to note: you will shoot yourself in the foot by doing this if you rely on AWS-bound traffic traveling through your office VPN.
    – EEAA
    Mar 16 '17 at 12:50
1

First install network-manager-openvpn and network-manager-openvpn-gnome.

Restart the network-manager service (check for your system)

sudo systemctl restart network-manager.service

and go to the Network Settings. From there add a new VPN

Add a new VPN

probably by choosing Import from file (.ovpn file).

After adding username and password go to the IPV4 tab and select the option Use this connection only for resources on its network

Choose the option image

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.