0

I can successfully run

check_snmp_mem.pl -v -H kvm.lala.bo -l bravo -x th3r4m1N+ -X j4bAdeHu5 -w 50,70 -c 80,90

but configuring "snmp-memory" check in Icinga2 is not working. Here's what I have in the config file for kvm.lala.by:

check_command = "snmp-memory"
host_name  = "kvm.lala.bo"
vars.snmp_v3 = "true"
vars.snmp_warn = "50,70"
vars.snmp_crit = "80,90"
vars.snmp_perf = "true"
vars.snmp_login = "bravo"
vars.snmp_password = "th3r4m1N+
vars.snmp_v3_use_privpass = "true"
vars.snmp_privpass = "j4bAdeHu5"

Icingaweb2 keeps printing

Can't mix snmp v1, 2c, 3 protocols! Usage: /usr/lib64/nagios/plugins/check_snmp_mem.pl [-v] -H -C [-2]

  • The remote host I'm trying to monitor is not made reference to anywhere but in /etc/icinga2/conf.d/lala.conf. – mr.zog Mar 19 '17 at 18:23
2

Not using the plugin, but I guess the problem is snmp_community having a default value. Please try setting it to false.

  • That's a good idea. – mr.zog Mar 21 '17 at 22:52
  • Actually this directive (snmp_community = "false") seems to have been ignored. I still see the same error. – mr.zog Mar 28 '17 at 1:50
  • Perhaps snmp_community = "" will work. – mr.zog Mar 28 '17 at 2:04
  • 1
    false would be a literal, when you define it as string/text, it will be the value of the community... – lazyfrosch Mar 29 '17 at 11:44
  • I tried snmp_community = false and that failed as well. – mr.zog Apr 1 '17 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.