0

I am currently facing the following weird problem: In a small workgroup there is an application installed on all clients that accesses a database and related files on a network share on a Windows 10 Machine in the same local network acting as the file share server.

And there is a problem i cant quite pinpoint.

Whenever accessing search/data functions in the applications and it needs to access the data on the server, there is a lot of delay, it is very slow, like it would be waiting for something in the background, sometimes like 30 seconds for just opening the basic database search form.

The thing is, I tried copying everything over to a small Synology NAS also in the same local network and tested it by changing the network share to there, it worked fine without delay in that configuration. The machine acting as the file server is a recent Windows 10 Pro machine with 16 GB RAM, so actually it should work better than the small NAS.

It has to be some Windows Setting on the machine, but which one? I searched everywhere but found nothing that resolved the issue. Any ideas are highly appreciated.

  • 1
    Windows 10 isn't a file server. Don't use it as such. Use the NAS or use an appropriate server OS. – joeqwerty Mar 23 '17 at 12:44
  • Agreed, NAS was designed for it, so the best way is to use your existing NAS as a file share. If not, just create an SMB share on top of any Windows Server OS. – Stuka Mar 24 '17 at 15:59
0

Windows client OS got a TCP/IP stack limit, while the Linux NAS got none of those limits, as it's probably a SAMBA configuration on a modified Linux OS.

You might receive such error too in the Windows 10 that serve as a server.

TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts.

So please use the NAS in the short term.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.