3

Have a single server site, running Windows 2012 R2

They had a long power cut, and the server uncleanly shut down when the UPS gave out.

We had a few other programs and database issues, but I've worked through them all, apart from Windows Server Update Service:

The WSUS MMC would not open, and just give an error (This has been going on for a few months, and the original message has been lost in the mists of time, but it was not the Manual steps needed for KB3159706).

WSUS was not installed using the Windows Internal Database: it's a separate 2012 R2 Express instance.

I've tried various fixes, including repairing the database, but couldn't get anything working, so I thought I'd try removing the WSUS Service and database roles.

In server Manager, I can't Add the WSUS Services and Datbase roles, as (reasonably) it's already installed.

In server manager, if I try to remove the Database role, I get this message:

The Request to Add or Remove features on the specified server failed. an unexpected event has occurred. You can view event logs in Event Viewer to learn more about possible causes for this problem. Error: 0x800f0831

Searching through event viewer (mainly the system and application logs), I can't track down any relevant events that seem to tie into this message.

Only bit I have managed to remove is the SQL Express instance using the SQL Add/remove programs feature.

Doing some googling on the error code, Windows Role adding and removal, and WSUS issues, I can't seem to find any info that applies.

Can anyone assist? In my mind, I'm hoping there's a procedure that basically says "Uninstall the role, ignoring any errors" (Or "Re-install/repair the roles over the top") which will let me add the roles from scratch - It's a very simple WSUS setup, so happy to just nuke the configuration, and start from scratch, if there's a way to do it.

Server manager Error

  • Are you able to remove some of the failing features? E.g. first remove the Console, then WID, then WSUS? Or are they all broken? I had to this many many times I'm afraid. If these steps fail, I'd walk you through the manual process (if possible). And: can you restart this particular server anytime you want? – Lenniey Mar 23 '17 at 15:30
  • Hi, Lenniey. Windows Internal Database was never installed (Used a separate 2012 Express instance) Under server manager, I have WSUS Services, and Database. If try to remove the database role solo, I get the Unexpected 0x800f0831 error (Again, still can't find it in the event log) If I try to remove WSUS Services, it also selects a lot of dependencies (Including Database), then gives the same error. I can restart this server at short notice without issue. – Dave Mar 23 '17 at 15:52
  • Alright. I meant database, not WID - as you said. Another question first: is this an important server? If not: I'd go on with a clean install of the OS. Corrupt WSUS installs can mess just about everything up... – Lenniey Mar 23 '17 at 15:55
  • Single server site, so it's everything: File, print, AD, and a few 3rd party apps that would cost more than a new server to move. – Dave Mar 23 '17 at 16:10
  • Phew, OK. We should move this to chat: chat.stackexchange.com/rooms/55913/wsus-corrupted – Lenniey Mar 23 '17 at 16:48
1

I had problem with RDS role (my collegue with IIS), the same error 0x800f0831. On Windows 2012 R2. The same error was when tried to install newest Cumulative update. Problem was caused by missing security update (KB4103725). You can find missing kb number in C:\Windows\Logs\CBS\CBS.Log when searching for '0x800f0831' but only when trying to install security patch and not restarted server (as log is cleared). Artur

0

I Had a colleague come and assist me with this one, and in the end, we did get it working. Rough steps below, in case anyone has the same issue.

1) Use SQL Express installer to remove the WSUS Database (We had a separate named instance instead of the Windows Internal Database)

2) Use This Article to manually remove WSUS

(In our case, the following keys wouldn't delete): HKEY_LOCAL_MACHINESoftwareMicrosoftWindowsCurrentVersionINstallerUserdatas-1-5-18Products Microsoft Windows Server Updates Services 3.0 HKEY_LOCAL_MACHINESoftwareClassesInstallProducts25B648799C414CF4EB36EF60FA054124 HKEY_CLASSES_ROOTWSusCertServer.CertManager HKEY_CLASSES_ROOTWSusCertServer.CertManager.1 HKEY_CLASSES_ROOTWSusUtilities HKEY_CLASSES_ROOTWSusUtilities.1

3) Remove the WSUS Role using server manager

4) Reboot, and Re-install WSUS using server manager. At this point, the installation worked, but the post installation tasks failed.

5) Work through This article to troubleshoot a failed WSUS installation - In Our case, removing the IIS and RAS Roles, rebooting, and re-adding them got WSUS to finish it's initialisation

At this point, client computers are showing back up in WSUS. Some are not reporting, but running a client side WSUS Reset is fixing that:

gpupdate /force
net stop wuauserv
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v NextDetectionTime /f
net start wuauserv
wuauclt /detectnow
pause
  • Quick Amendment: The Windows 10 clients started reporting fine, but the Windows 7 clients registered in the WSUS, but did not ever report. The fix was to install the latest Windows Update Client from support.microsoft.com/en-nz/help/3138612/… I'm hoping that now their reporting, they'll stay working after the next Windows Update Client update. – Dave May 30 '17 at 9:06

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.