0

I have a server running Windows Server 2008 R2 as a domain controller. I have a number of Windows 7 x64 Professional machines. I am trying to set Remote Desktop privileges to all users to login to all my domain machines.

I have set the User Rights Assignment for Allow user to login through Terminal Services (Remote Desktop) to Authenticated users, Users, & Remote Desktop users. I have added Authenticated Users to the Remote Desktop Users group in Active Directory. I have also gone into Group policy and enabled the following setting:

Computer Management Policies->Administrative Template->Windows Components ->Remote Desktop Services-> Remote Desktop Session Host ->Connections ->Allow users to connect remotely using Remote Desktop Services

Users still cannot login. I am entirely confused. I have to many machines to go to individually and grant access. Can anyone suggest a step I am missing?

5

The Remote Desktop Users group in AD controls RDP access to Domain Controllers. It has no bearing on the local Remote Desktop Users group or RDP access to domain joined computers that are not Domain Controllers. For those computers you'll need to use Group Policy Preferences or Restricted Groups to modify the membership of the local Remote Desktop Users group.

enter image description here

  • Can you elaborate? Should I make a new Remote Desktop Users group and add users to it? I have added Authenticated Users and Users to the GPO User Rights Assignment for this but that did not work either. – JukEboX Mar 23 '17 at 19:35
  • And this is also not true. The group in the description allows for Remote Desktop to machines on the domain. – JukEboX Mar 23 '17 at 19:38
  • 7
    It does not grant RDP access to computers in the domain. If it did it would be working for you. The domain Remote Desktop Users group grants RDP access only to Domain Controllers. You need to modify the local Remote Desktop Users group on the local computers. You can disagree with me if you like, but until you do that it isn't going to work. – joeqwerty Mar 23 '17 at 19:43
  • Thanks for the info. Wasn't as clear as I needed and I was also confused about your first answer. Guess we both were on the same page but in a different way. – JukEboX Mar 23 '17 at 21:26
  • I updated your question with the picture I and information. Deleted my answer. Thanks again. – JukEboX Mar 23 '17 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.