0

So I have a Windows Server 2012 R2, with IIS 8.

I have a website setup in IIS that hosts a webservice (old-school webservice .asmx), also on the same server is SQL DATA TOOLS and an SSIS package.

I need the SSIS package to be able to use the webservice hosted in IIS but I need to lockdown access to the webservice so that it is not available to the outside world.

How do I make it so my SSIS package can access it but to the outside world it is restricted?

So far I have tried:

adding a ip address allow entry for my web servers ip and then selecting 'edit feature setting' and denying all unspecified clients.

This does not work, my webservice is inaccessible to my SSIS package

0

Add 127.0.0.1 to the IP allow list in the IP restrictions module in addition to the external address that I assume you've already added.

If this doesn't work then check if you have any IPv6 addresses bound to your network adapter and add these as well (ignore ::1, this is treated the same as 127.0.0.1 by IIS, you don't need to add both)

  • Great, thank you, I should have thought of that. Appreciate the help, really – Matthew Stott Mar 25 '17 at 15:02
  • Sorry, what do you mean by in addition to the external address that I assume you've already added – Matthew Stott Mar 25 '17 at 17:20
  • I get HTTP Error 401.2 - Unauthorized You are not authorized to view this page due to invalid authentication headers. – Matthew Stott Mar 25 '17 at 17:31
  • Ok, I'm reasonably sure that error isn't because of IP restrictions. Try turning them off temporarily and see if it works. What authentication methods do you have enabled in the site? Does it allow anonymous authentication? If not, is the SSIS package setup to authenticate in the required way? – Steve365 Mar 25 '17 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.