just finished provisioning a new hpe dl380g9 server with hyperv server 2016. Installed it on microsd (yes, it is supported by HPE). All recommended updates installed.

Everything seemed smooth but now, provisioning VMs I have a major trouble. Being them either Linux or Windows VM, if I try to restart a VM, what I got MOSTLY is just a Stop. Now and then the VM actually restarts.

I've tried to restart the entire server but issue is still here!

Issuing several

stop-VM; start-VM

seem to work.

I post here some system settings:

hyper-v server is on microsd

VM are in 2 arrays each one managed by a raid controller.

when a VM is created in array 1 I (think to) put all required files (from definitions to paging) into such an array, nothing is kept on the sd.

the only actual change to hyper-v server (other than HPE drivers installed by windows at automatically at install time) is that I've disabled the paging file.

I've tested a number of VM (linux, windows) all gen2, with windows defender either ON or OFF on the host.

all VM have dynamic vhdx and dynamic memory.

Honestly I don't even know from where to start sorting this out.

Any hint? Thank you!

  • 1
    TBH, disabling the pagefile is a non-standard configuration. As a first step, try enabling the pagefile and see if that resolves the issue.
    – joeqwerty
    Mar 24, 2017 at 18:01
  • Have a look at the event log; that's always the first troubleshooting step.
    – Massimo
    Mar 24, 2017 at 18:12

1 Answer 1


That was an issue with the default location of vVMs smart paging file. Keeping it at default suggested location solved. Also reinstalled controller drivers just in case...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.