0

I'm trying to set up a Gentoo guest on a virtio drive. When I boot the VM using an ubuntu livecd, I do have a /dev/vda on which I installed the system using LVM. I compiled a 4.9.16-gentoo kernel enabling basically everything with virtio in the name that I could find, and then generated an initrd using dracut (since my root is on LVM), but when I boot I get dropped in the dracut shell and I can see there isn't any /dev/vda existing.

Since it works fine on the livecd, I must be missing something in my kernel config, any ideas ? I googled a bunch but it seems hard to find a real list of what you need to get virtio to work, at least not up to date.

Here is the kernel config I'm using now, probably too much stuff enabled but I'm just trying to figure out what I'm missing https://datas.ulrar.net/config_virtio

Thanks

0

Figured it out, apparently virtio legacy is required. I've read that the "modern" implementation isn't ready and therefore isn't enabled by default in qemu, but Linux > 4 still renamed the actual stable implementation to legacy. Sounds a bit silly, but enabled legacy virtio pci in the kernel works ..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.