-3

I have an Ubuntu server that has recently been intermittently slow to respond - 30s+ to connect to ssh or web servers, and New Relic shows regular interruptions in the data (but no actual activity).

Every time I look at it the load average is under 0.1. I can't see signs of excessive activity in any of the services running.

If there is no sign of activity on the server how can I find what is making it slow to respond?

  • Sounds like a network problem. – kasperd Mar 27 '17 at 21:55
  • Details about how to identify said network problem could be most helpful. In any case this error is resolved but if there was a different error that caused the same result I'm not sure how it could be tested. – user29745 Mar 27 '17 at 22:12
  • It is simply not possible to narrow the problem down any further with the information provided in the question. – kasperd Mar 28 '17 at 19:24
  • That is exactly why it was asked, I thought there might be some additional ways to narrow it down when all the normal steps failed. – user29745 Mar 29 '17 at 1:58
0

It turns out this is a recent issue with Ubuntu (and also a second issue that applies to certain Digital Ocean servers). DNS lookups were failing which caused delays on everything running there. It was resolved by installed updated packages with apt-get.

Full details are listed at https://www.digitalocean.com/community/questions/how-to-fix-the-march-2017-ubuntu-dns-resolution-issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.