4

Question

Why is DHCP showing "BAD_ADDR", why does it think there is a Conflict, and why can't the host register its DNS name?

Devices:

DHCP Server = Server 2012 on bare metal. Also running DNS.

Host = Ubuntu 16 Server on ESXi. For testing purposes, before any steps below are performed, the server is shut down and given a new virtual NIC with a new MAC Addr.

Symptoms

-Host boots.

-A DNS Update Request appears in the DHCP log for Host.AD.MyDomain.com.

-An IP is assigned to Host.AD.MyDomain.com.

-Another DNS Update Request appears in the log for said host.

-The log then shows "Conflict, IP, BAD_ADDRESS

-DNS Update fails.

-Another DNS Update Request appears, now with a 2nd IP.

-2nd IP is also assigned to said host.

-Conflict, IP, BAD_ADDRESS shows up again.

-DNS Update fails again.

-"ip addr show" on the host shows both IPs and the host is able to communicate with the network in all ways except it cannot be reached by hostname from any other machine.

-Host can ping its own hostname.

Relevant Logs

30,03/28/17,11:23:29,DNS Update Request,10.166.2.8,Host.AD.MyDomain.com,,,0,6,,,,,,,,
10,03/28/17,11:23:29,Assign,10.166.2.8,Host.AD.MyDomain.com,00505600BBAA,,282418132,0,,,,,,,,
30,03/28/17,11:23:30,DNS Update Request,10.166.2.8,Host.AD.MyDomain.com,,,0,6,,,,,,,,
13,03/28/17,11:23:30,Conflict,10.166.2.8,BAD_ADDRESS,,,0,6,,,,,,,,
31,03/28/17,11:23:30,DNS Update Failed,10.166.2.8,Host.AD.MyDomain.com,,,0,6,,,,,,,,
30,03/28/17,11:23:32,DNS Update Request,10.166.2.24,Host.AD.MyDomain.com,,,0,6,,,,,,,,
10,03/28/17,11:23:32,Assign,10.166.2.24,Host.AD.MyDomain.com,00505600BBAA,,1734739418,0,,,,,,,,
30,03/28/17,11:23:32,DNS Update Request,10.166.2.24,Host.AD.MyDomain.com,,,0,6,,,,,,,,
13,03/28/17,11:23:32,Conflict,10.166.2.24,BAD_ADDRESS,,,0,6,,,,,,,,
31,03/28/17,11:23:32,DNS Update Failed,10.166.2.24,Host.AD.MyDomain.com,,,0,6,,,,,,,,

Other Information

No other host on the network has this issue, which leads me to believe it is something wrong with the Ubuntu Server. Previous to this happening today, the server never had an issue and was able to be reached by hostname by all other hosts. The DHCP server is set to allow devices to register their DNS name with the server.

There are no Rogue DHCP Servers.

There is no ARP Proxy.

I have tried rebooting the DHCP Server.

I have checked DNS for old entries of said host, there are none.

This is definitely not an issue of duplicate MAC Addr. I have tried with several virtual NICs which different MAC Addresses, all have the same issue.

There is no other host on the network with the same hostname.

This may not be relevant, but I am curious as to why the DHCP log shows a DNS Update Request with IP "X", before it shows IP "X" being assigned. Perhaps Windows logs those events out of order?

  • 1
    multiple nic in dhcp's mode ? – yagmoth555 - GoFundMe Monica Mar 28 '17 at 16:14
  • @yagmoth555 Apologies, unfamiliar with the term "dhcp's mode". The DHCP server has a 2nd NIC but it is disabled. – Copy Run Start Mar 28 '17 at 17:59
  • I mean more, the remote machine is multihomed with more than one nic on the same network as the dhcp's server ? or with a teamed nic ? – yagmoth555 - GoFundMe Monica Mar 28 '17 at 20:50
  • @yagmoth555 The host machine has only one NIC. It is a virtual NIC as it is an esxi guest. – Copy Run Start Mar 28 '17 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.