3

while trying to mount google bucket or set sshfs up I am getting following error:

fusermount: fuse device not found, try 'modprobe fuse' first

modprobe fuse command does not show anything:

[user@drive ~]# modprobe fuse
[user@drive ~]#

fuse is installed

[user@drive ~]# yum list installed | grep fuse
fuse.x86_64                           2.9.2-7.el7              @base
fuse-devel.x86_64                     2.9.2-7.el7              @base
fuse-libs.x86_64                      2.9.2-7.el7              @base
fuse-sshfs.x86_64                     2.5-1.el7                @epel
gcsfuse.x86_64                        0.21.0-1                 @gcsfuse
libconfuse.x86_64                     2.7-7.el7                @epel
[user@drive ~]#

fuse is not loaded after modprobe

[user@drive ~]# lsmod | grep fuse
[user@drive ~]# 
[user@drive ~]# lsmod
Module                  Size  Used by
[user@drive ~]#

installation details

Operating System: CentOS Linux 7 (Core)
     CPE OS Name: cpe:/o:centos:centos:7
          Kernel: Linux 2.6.32-042stab120.19
    Architecture: x86-64
  • 1
    modprobe only prints output on error. Did you try sshfs again after modprobe? Check that the fuse module is loaded in the kernel after modprobe: lsmod | grep fuse – Andrew Domaszek Mar 31 '17 at 8:18
  • I tried and getting same error. lsmod | grep fuse shows nothing. lsmod shows nothing too – m1k3y02 Mar 31 '17 at 8:41
  • Any chance a resolution was found? I'm stuck on this same issue. – swv Dec 21 '17 at 7:51
  • In my case I had to change VPS provider... This was an issue with the OS image which couldn't be altered to include fuse for whatever reason – m1k3y02 Jul 10 '18 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.