0

I would like to mount my qnap to my Linux Mint laptop. The IP address of the NAS is : 192.168.0.25

So I executed this command:

sudo mount -t nfs -o username=user_name,password=my_password 192.168.0.25:HR /mnt/qnap

I had this error:

mount.nfs: an incorrect mount option was specified

When I use the UI and click on Network then MyNas icon, I had this error:

Failed to retrieve share list from server: Connection refused

Do you see any solution ?

== Update ==

This is the showmount command output:

showmount -e 192.168.0.25

Export list for 192.168.0.25:
/homes       
/my_home       
/Web         
/Public      
/OceanKTV    
/Multimedia  
/Download    
/Container  
  • Not 100% sure this question's right for serverfault but either way what happens when you do 'showmount -e 192.168.0.25'? – Chopper3 Mar 31 '17 at 12:27
  • @Chopper3 thanks. Please see the update in my post. – 4m1nh4j1 Mar 31 '17 at 12:31
  • 1
    Ok...so which mountpoint are you going for, there's not one called 'HR' – Chopper3 Mar 31 '17 at 12:32
  • mounting any of these folders gives the same error – 4m1nh4j1 Mar 31 '17 at 12:35
2

There is neither a username nor a password option for NFS mounts. A typical NFS mount command looks like as follows.

sudo mount -t nfs 192.168.0.25:/Multimedia /mnt

For further mount options you can refer to the manpage of NFS.

  • why shouldn't I put a login/password ? How can I authenticate then ? I found this in wiki.qnap.com/wiki/Mounting_an_NFS_share_on_Ubuntu – 4m1nh4j1 Apr 27 '17 at 10:06
  • Because NFS does not work that way. Unless you have NFSv4, there is no user authentication. With NFSv4, the only way for authentication is kerberos, which does not need username/password but works with "tickets". In NFSv3 and below, you only can allow/disallow a network segment or single hosts or netgroups. – Thomas Apr 27 '17 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.