Our two server SharePoint 2007 SP2 farm has an issue. Event ID 6482 appears in the Application log of the Web front end many times a day. Often many time a minute.

The full error is from Office SharePoint Server

Event Type: Error
Event Source:   Office SharePoint Server
Event Category: Office Server Shared Services 
Event ID:   6482
Date:       11/12/2009
Time:       3:05:22 PM
User:       N/A
Computer:   XXXXXX
Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (36a9b7ef-59aa-4f94-8887-8bf7b56f2f91).

Reason: Error during encryption or decryption. System error code 0.

Techinal Support Details:
System.ArgumentException: Error during encryption or decryption. System error code 0.
   at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.SynchronizeDefaultContentSource(IDictionary applications)
   at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
   at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

The SharePoint site appears to be functioning normally and Search returns expected results.

Any suggestions would be appreciated


Found this tip from MS. Avoids the mess of password resets. Unfortunately, errors return after a few minutes

Before trying to reset the password, you could try to clear SharePoint configuration cache on all your SharePoint servers and see if it is helpful for your issue. To clear SharePoint configuration caches, please follow the steps:

  1. Stop Windows SharePoint Services Timer in Services.
  2. Locate the configuration cache folder in %allusersprofile%\Application Data\Microsoft\SharePoint\Config\GUID In Windows Server 2008, the configuration cache is in the following location: %allusersprofile%\Microsoft\SharePoint\Config\GUID
  3. Back up the Cache.ini file.
  4. Delete all the XML configuration files in the GUID folder.
  5. Edit the Cache.ini file. Change the content to 1, and then click Save the changes.
  6. Start Windows SharePoint Services Timer in Services. See KB 939308 ( http://support.microsoft.com/kb/939308 ) for more information.

Sounds like the server is using cached credentials. Did you just change the password for a service account? Assuming so, did you use stsadm to make the change?

KB 934828 outlines how (note the extra 2 steps if you're running in a least-privilege setup)

  • Thanks Vinny. We will check that but credentials have not changed – Dave M Nov 12 '09 at 20:47
  • Hmm. Anything interesting under the CA location below? Central Administration > Application Management > Check Services Enabled in this Farm – vinny Nov 12 '09 at 22:50
  • No issues reported there – Dave M Nov 13 '09 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.