3

550 maximum allowed line length is 998 octets, got 1014

Getting this error in emails bouncing back. Is there a setting in exim to solve this problem?

Tried to google it up but cannot find any solution.

  • Bouncing back, as in: the other mailserver bounces the mails, or yours? – Lenniey Apr 3 '17 at 8:23
  • It is mine. I think I have found the problem. I have increased the setting message_size_limit = ${if > {$max_received_linelength}{1014} {1}{0}} i exim4.conf.template Is this ok to do? – Fabrizio Mazzoni Apr 3 '17 at 8:27
  • Please provide the output of exim4 -bP message_size_limit, you shouldn't have to alter any template, but set the message_size_limit via conf-file. – Lenniey Apr 3 '17 at 8:40
  • Command returns message_size_limit = 50M – Fabrizio Mazzoni Apr 3 '17 at 8:41
  • Didn't realize the error was based on the number of recipients and CC...sorry. Check @EsaJokinens answer – Lenniey Apr 3 '17 at 9:43
2

The error you got is based on RFC 2822 / RFC 5322 (Internet Message Format):

2.1.1. Line Length Limits

There are two limits that this specification places on the number of characters in a line. Each line of characters MUST be no more than 998 characters, and SHOULD be no more than 78 characters, excluding the CRLF.

The 998 character limit is due to limitations in many implementations that send, receive, or store IMF messages which simply cannot handle more than 998 characters on a line.

2.2.3. Long Header Fields

Each header field is logically a single line of characters comprising the field name, the colon, and the field body. For convenience however, and to deal with the 998/78 character limitations per line, the field body portion of a header field can be split into a multiple-line representation; this is called "folding". The general rule is that wherever this specification allows for folding white space (not simply WSP characters), a CRLF may be inserted before any WSP.

As every decent email client probably conforms to this standard you probably won't reject anything but SPAM if you don't even consider this as a problem and try to solve it.

If you have a long list of addresses in CC: field, your email client should add line breaks before the 988 character line length limit. As the mean email address length is 23 characters, that would be approximately 43 addresses per line. If you need to send an email to this many recipients, please consider using BCC: field (or a mailing list software with opt-out possibility) instead.

2

Apparently exim has set this limit. This link describes how to modify the

exim4.conf.template in order to avoid messages being rejected.

It's just the case to add IGNORE_SMTP_LINE_LENGTH_LIMIT=1 to the template and regenerate the config file with update-exim4.conf

  • Well you can disable it. I leave my Exim alone because why would I want to receive email from people who can't be bothered to follow standards... but that's me. – Zan Lynx Nov 6 '19 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.