Eventhough i killed the nginx process still it is running ..

I did the following steps 1)Finding the process PID using netstat -n -a -o | findstr "" and killing it with taskkill /F /PID 52544 2)Even i tried giving taskkill /F /IM nginx.exe in command prompt

Now when i use netstat -n -a -o | findstr "" i dont see any process running on port 80 but still i can see the nginx homepage in port 80?

I dont know how to stop that process


  • Have you tried just stop nginx's service? – Alexey Ten Apr 4 '17 at 8:39
  • yeah i tried that one too.It is throwing error like this failed (2: The system cannot find the file specified) – Private Apr 4 '17 at 8:39
  • Is it maybe cached? Ctrl+F8 – mzhaase Apr 4 '17 at 9:36
  • Yeah, the problem is with browser since it is using autofill option . When i unchecked autofill and cleared the cache now i can see nginx is stopped. – Private Apr 4 '17 at 9:43

Use nginx -s stop to stop all nginx processes

  • You'll have to navigate to the folder where NGINX is installed first and then the above command nginx -s stop shown by Endogen will work. – Raymond Wachaga Feb 11 at 20:46

First Way (Manually):

Know the /PID by Command: tasklist /fi "imagename eq nginx.exe" and taskkill /f /pid *pid of nginx.exe*.

Second Way (Pragmatically):

If you want to terminate with batch script (save as nginx_terminator.bat):

@echo off
::=======NGINX TERMINATER========
::[Author:WinPhay Date:8.29.2017]
tasklist | find /i "nginx.exe">nul  && Taskkill /F /IM  "nginx.exe" & exit/b
timeout /t 30

For more information read the Nginx for Windows documentation.


You can use the code taskkill /f /IM nginx.exe in cmd for removing all the running nginx process in windows

Or use nginx -s stop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.