I am running Volumio on my RasPi and I want to export the internal storage directory (/data/INTERNAL) so that anyone may mount it to add/remove music. When I run 'exportfs -a' I get the following message:

exportfs: /data/INTERNAL does not support NFS export

I was running into this issue trying to export from my encrypted /home/folder on my Ubuntu machine however Volumio doesnt use encryption (to my knowledge).

Interestingly, when I run 'showmount -e' (server-ip) from the from the client (Ubuntu 14.04) it returns the following:

Export list for /data/INTERNAL

I thought perhaps this was just a bug so when I went to mount from the client with 'sudo mount /nfs' it returns this:

mount.nfs: access denied by server while mounting

(note: I have also tried mounting with 'sudo mount -t nfs -o proto=tcp,port=2049 /nfs' and 'sudo mount -o v3 /nfs' each with the same output)

I have set /data/ permissions recursively to 777 and here is my /etc/exports output:

# /etc/exports: the access control list for filesystems which may be exported
#       to NFS clients.  See exports(5).
# Example for NFSv2 and NFSv3:
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)

Im pulling my hair out over this one.


This ia perhaps due to selinux context. I think you should check the context :

ls -dZ /data/INTERNAL 

If it is something other than public_content_rw_t, try changing it :

semanage fcontext -a -t public_content_rw_t '/data/INTERNAL(/.*)?'

After that run the restorecon command -

 restorecon -RvF /data/INTERNAL

Now try exportfs -a .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.